Project

General

Profile

Bug #812

RRD graph time axis not locked to latest times with higher average samples

Added by Mr Horizontal almost 9 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
RRD Graphs
Target version:
Start date:
08/08/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

See attached chart - this was taken on Sunday 20:12, but the chart shows the x-axis to Monday 0.00...

This is the case especially with the 1 day range chart, but exists to a lesser extent to all greater ranges than the 1 minute average charts.

status_rrd_graph_img.php.png (24.4 KB) status_rrd_graph_img.php.png Mr Horizontal, 08/08/2010 03:21 PM

History

#1 Updated by Chris Buechler over 8 years ago

This change was by design as it shows the full period rather than up to now (where 1 day = midnight to midnight). It's better to revert back to the way it previously was, just reverting the time frame change on the graphs.

#2 Updated by Seth Mos over 8 years ago

It took me a great while and I've just remembered some of the how and what.

The gist of it is this, we do not have enough samples to make a 24 hour graph. Iirc we have enough samples to do a 16 hour graph at most.

The start from sunday 00:00 to monday 00:00 is exactly 1 24 hour day. Ending the graph on a 23:59 might seem more intuitive but is next to impossible to do.

I previously had a 8 or 12 hour graph which can utilize the the 1 minute averages but that turned out to be a problem to generate. Technically the code to generate a 8 or 12 hour graph is not a issue. The code is still there. The biggest problem is getting the math right for the start and end date.

What to do when the 8 or 12 hour graph rolls around. E.g. the 8 hour is 0, 8 and 16 for the start, the 12 hour is either midnight or noon. Not sure what makes more sense here.

#3 Updated by Seth Mos over 8 years ago

  • Status changed from New to Feedback

I have just committed a 8 hour graph in git that should do what I outline above

#4 Updated by Chris Buechler about 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF