Project

General

Profile

Actions

Bug #8208

closed

Restoring a config in 2.4.2 with 2.3.X Security/Errata Only repo selected breaks PHP

Added by Paighton Bisconer almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Category:
Configuration Upgrade
Target version:
Start date:
12/13/2017
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.2
Affected Architecture:

Description

After attempting to repair repos for a failed upgrade, config was exported from 2.3.4-P1 and imported to a fresh install of 2.4.2.

Console began spitting errors citing "/etc/inc/certs.inc line 44".

Cause was found to be 2.3.X Security Errata Only repo selected before config export.

"<pkg_repo_conf_path>/usr/local/share/pfSense/pkg/repos/pfSense-repo-legacy-23.conf</pkg_repo_conf_path>"

Setting repo to 2.4.X prevents the issue.

Actions #1

Updated by Jim Thompson almost 4 years ago

  • Assignee set to Renato Botelho
Actions #2

Updated by Jim Pingle over 3 years ago

  • Target version changed from 2.4.3 to 2.4.4
Actions #3

Updated by Jim Pingle over 3 years ago

  • Target version changed from 2.4.4 to 2.4.3
Actions #4

Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Paighton Bisconer over 3 years ago

2.3.4 Config with 2.3.X Errata Repo restored to 2.4 systems will break.
2.3.4 Config with 2.4.X Repo restored to 2.4 works as expected.
2.4.2-p1 Config with 2.3.X Errata Repo restored to 2.4.3-DEV (Pre-8208 fix) will break.
2.3.4 or 2.4.2-p1 Config with 2.3.X Errata Repo restored to 2.4.3-DEV (Post 8208 fix 2.4.3.a.20180313.1628 or later) works as expected and the issue is resolved.

Actions #6

Updated by Renato Botelho over 3 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF