Project

General

Profile

Actions

Bug #829

closed

WAN stays assigned to pppoe0 interface after switching type from PPPoE to Static

Added by Paul K over 11 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
08/18/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

To reproduce:
- configure WAN as PPPoE
- switch WAN from PPPoE to Static
- go to 'Interface Assignments' page and you will see that WAN is still assigned to pppoe0 interface

Using embedded i386 snap from Sun Aug 15 10:26:54 EDT 2010


Files

Actions #1

Updated by Chris Buechler over 11 years ago

  • Target version set to 2.0
Actions #2

Updated by Ermal Luçi over 11 years ago

Can you please provide more details on this.
If possible the config.xml file before and after the issues shows.

To be clear you have assigned a pppoe interface create on interface->assignment->ppp or you have just configured pppoe on the Interface->wan interface while the assignment is a normal interface?

Actions #3

Updated by Paul K over 11 years ago

PPPoE was configured on the Interface->wan page by selecting type = pppoe. I will try to reproduce it on a VM box and attach config files.

Actions #4

Updated by Paul K over 11 years ago

I just reproduced it on VM running 'Aug 18 21:58:53 EDT 2010 ' snappy.

3 files attached:

Actions #6

Updated by Paul K over 11 years ago

file 1 - PPPoE config
file 2 - WAN changed from PPPoE to static
file 3 - static config after I manually changed WAN assignment from pppoe0 to em0

Actions #7

Updated by Ermal Luçi over 11 years ago

  • Status changed from New to Feedback

I investigated this and for now i just put a warning message there to tell you that you have to reassign the interface.
For 2.1 this will need to be fix together with some other things which are not trivial at the moment.

Thank you for reporting this and for the feedback.

Actions #8

Updated by Paul K over 11 years ago

Hi Ermal, I tried testing it, but could not get it to work.

My WAN is configured as PPPoE to begin with:

- I go to Interfaces WAN and change type from PPPoE to Static, enter IP and click save -> error message shows up 'You have to reassign the interface to be able to configure as static.' I guess that's an expected behaviour.
- Now I go to Interfaces -> assign and change WAN from PPPoE(vr1) to vr1 and click save -> page just keeps loading (I waited 5 min and it was still loading); If I compare backup before this step and after I see that WAN was reassigned from pppoe0 to vr1
- I now go back to WAN page and see that all my PPPoE settings are blank (good sign I guess), change type to static, click save and I am presented with the error message again.
- go back to interfaces assign page and WAN is assigned vr1; so I am kind of stuck in a loop.
Actions #9

Updated by Alexandre Paradis almost 11 years ago

I have the same problem from pppoe to DHCP.

2.0-BETA4 (i386)
built on Fri Dec 3 15:21:00 EST 2010

Actions #10

Updated by Chris Buechler almost 11 years ago

  • Status changed from Feedback to New
Actions #11

Updated by Ermal Luçi almost 11 years ago

  • Status changed from New to Feedback
Actions #12

Updated by Alexandre Paradis almost 11 years ago

Right now it seems to work, but my pppoe was on a OPT1 interface, i will try again on another box with pppoe as primary wan interface.

Actions #13

Updated by Alexandre Paradis almost 11 years ago

Alexandre Paradis wrote:

Right now it seems to work, but my pppoe was on a OPT1 interface, i will try again on another box with pppoe as primary wan interface.

but my pppoe IS on a OPT1 interface

fixed. sorry for the typo.

Actions #14

Updated by Ermal Luçi almost 11 years ago

It does not matter really if it was WAN/LAN/OPT# ... Just test if it works as you expect.

Actions #15

Updated by Alexandre Paradis almost 11 years ago

Ermal Luçi wrote:

It does not matter really if it was WAN/LAN/OPT# ... Just test if it works as you expect.

then it should be fixed. it was probably fixed with another fix during december.

Actions #16

Updated by Ermal Luçi almost 11 years ago

  • Status changed from Feedback to Resolved
Actions #17

Updated by o s about 8 years ago

Pfsense 2.1-RELEASE (amd64)
built on Wed Sep 11 18:17:37 EDT 2013
FreeBSD 8.3-RELEASE-p11

This exact bug just happend to me right now, seems not resolved anymore.

Actions #18

Updated by Caesar Caesar almost 8 years ago

Same issue on 2.1-RELEASE (i386)
built on Wed Sep 11 18:16:50 EDT 2013
FreeBSD 8.3-RELEASE-p11

Actions #19

Updated by Caesar Caesar almost 8 years ago

It seems a workaround is to set the interface to static, type an IP, then submit the changes. Once you do this, you can set it to DHCP.

Actions #20

Updated by James Simas almost 8 years ago

Hello,

I just experienced this issue. My pfSense build is:

2.1-RELEASE (i386)
built on Wed Sep 11 18:16:50 EDT 2013
FreeBSD 8.3-RELEASE-p11

I was able to work around this issue using the steps which Caesar Caesar mentioned in comment #19.

James

Actions #21

Updated by Chris Buechler almost 8 years ago

  • Status changed from Resolved to New
  • Target version changed from 2.0 to 2.1.1
  • Affected Version changed from 2.0 to 2.1
Actions #22

Updated by Ermal Luçi almost 8 years ago

  • Status changed from New to Feedback

I cannot reproduce this.
And there is already code taking care of this since:

commit 8b1e7d04da1a2e1cefbad4b595033cedff4685e5
Author: Ermal <eri@pfsense.org>
Date:   Wed May 4 21:54:10 2011 +0000

    Correct wrong key for checking if a interface type switched. Ticket #1420

Actions #23

Updated by Chris Buechler over 7 years ago

  • Status changed from Feedback to Resolved

this works as it should

Actions

Also available in: Atom PDF