Project

General

Profile

Bug #8305

acme: "Key Size" value is not passed to acme.sh

Added by Idar Lund over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
ACME
Target version:
-
Start date:
01/30/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:

Description

Setting a "Key Size" in acme_certificates_edit.php has no effect. This variable is not passed on to the /usr/local/pkg/acme/acme.sh script.
Expected behaviour would be that the value in "Key Size" is passed as "-k value" to acme.sh script.

History

#1 Updated by Jim Thompson over 2 years ago

  • Assignee set to Jim Pingle

#2 Updated by Jim Pingle over 2 years ago

Turns out this is a quirk in acme.sh and not our code, but I put in a fix on our version since it isn't certain it's actually a bug upstream. Fix will be coming shortly.

#3 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Fix committed, will show up in 2.4.3 snaps first, next time the other branches get an ACME update it will work there, too.

#4 Updated by Idar Lund over 2 years ago

Jim Pingle wrote:

Fix committed, will show up in 2.4.3 snaps first, next time the other branches get an ACME update it will work there, too.

I'm on 2.4.2. Will test it as soon as it's committed there as well and give you feedback.

#5 Updated by Jim Pingle over 2 years ago

It's available on 2.4.2 right now, in ACME package version 0.2.1.

You will need to create a new certificate entry in order for it to work, renewing an existing entry will not generate a new private key.

#6 Updated by Idar Lund over 2 years ago

Jim Pingle wrote:

It's available on 2.4.2 right now, in ACME package version 0.2.1.

You will need to create a new certificate entry in order for it to work, renewing an existing entry will not generate a new private key.

works perfectly!

#7 Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved

Great, thanks for testing!

Also available in: Atom PDF