Project

General

Profile

Bug #8413

Virtual IP on PPPOE interface no longer working with 2.4.3

Added by Foo Barbarian over 2 years ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/01/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3
Affected Architecture:

Description

When upgrading from 2.4.2 to 2.4.3 the IP aliases on the PPPOE interface stopped working.

Before upgrading they were set up as IP Alias on the localhost interface.

Where 123.123.55.49 is the DHCP address on the PPPOE0 interface and 123.123.1.189 is inside the static /29 assigned by the ISP.

Now using localhost or PPPOE interface for IP alias results in an error:
The command '/sbin/ifconfig 'pppoe0' inet '123.123.1.189'/'29' alias ' returned exit code '1', the output was 'ifconfig: ioctl (SIOCAIFADDR): Destination address required'

Running this via shell will bring the IP alias back up:
/sbin/ifconfig 'pppoe0' inet '123.123.1.189'/'29' alias 123.123.55.49

History

#1 Updated by Jim Pingle over 2 years ago

  • Project changed from pfSense Packages to pfSense
  • Status changed from New to Duplicate

Duplicate of #8393

#2 Updated by Foo Barbarian over 2 years ago

Not sure this is a duplicate as it also affects PPPOE interfaces and not just on startup. Also happens when trying to configure PPPOE during runtime.

#3 Updated by Foo Barbarian over 2 years ago

This is not duplicate of #8393 - I've applied the patches of #8393 and it does not resolve the issue

#4 Updated by Felix Wolfsteller about 2 years ago

Same (error in log) happening here, but already on version 2.4.1-RELEASE (amd64) . PPOE-interface with virtual IPs (various combinations).

#5 Updated by Nick R 9 months ago

Hi,

I am getting this exact same error when my PPPoE connection drops and pfSense tries to reestablish it.

At least one of the servers behind a virtual IP is having trouble establishing new connections one this happens.

This is with 2.4.4-RELEASE-p3 (amd64) so the problem is definitely still not fixed...

Nick

Also available in: Atom PDF