Project

General

Profile

Actions

Bug #8522

closed

SMTP test says success when actually fails

Added by Jeremy  99 over 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Very Low
Category:
Notifications
Target version:
Start date:
05/15/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

Bug:
When I clicked the "Test SMTP Settings" button, I got a green message "SMTP testing e-mail successfully sent" but I never received the email. I then realized that I forgot to type anything in the "E-Mail server" textbox.

Expected behavior:
The GUI should have a red message saying "Could not send a test email because you haven't specified the SMTP Server and port."

Actions #1

Updated by Jim Pingle about 2 years ago

  • Category set to Notifications
Actions #2

Updated by Viktor Gurov over 1 year ago

This PR adds extra input validation:
https://github.com/pfsense/pfsense/pull/4218

Actions #3

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.5.0
Actions #4

Updated by Renato Botelho over 1 year ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

Actions #5

Updated by Viktor Gurov over 1 year ago

  • Status changed from Feedback to Resolved

works as expected on 2.5.0.a.20200331.2303

Actions

Also available in: Atom PDF