Project

General

Profile

Bug #8522

SMTP test says success when actually fails

Added by Jeremy  99 over 2 years ago. Updated 7 months ago.

Status:
Resolved
Priority:
Very Low
Category:
Notifications
Target version:
Start date:
05/15/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:

Description

Bug:
When I clicked the "Test SMTP Settings" button, I got a green message "SMTP testing e-mail successfully sent" but I never received the email. I then realized that I forgot to type anything in the "E-Mail server" textbox.

Expected behavior:
The GUI should have a red message saying "Could not send a test email because you haven't specified the SMTP Server and port."

Associated revisions

Revision d5155a01 (diff)
Added by Viktor Gurov 8 months ago

Notifications page input validation. Issue #8522

History

#1 Updated by Jim Pingle about 1 year ago

  • Category set to Notifications

#2 Updated by Viktor Gurov 8 months ago

This PR adds extra input validation:
https://github.com/pfsense/pfsense/pull/4218

#3 Updated by Jim Pingle 8 months ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.5.0

#4 Updated by Renato Botelho 8 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#5 Updated by Viktor Gurov 7 months ago

  • Status changed from Feedback to Resolved

works as expected on 2.5.0.a.20200331.2303

Also available in: Atom PDF