Project

General

Profile

Bug #8618

2.4.4 *possible bug* with Intel C3858 and Interface Auto-Detection on 10Gb interfaces

Added by Kevin Boatswain over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
07/04/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
amd64

Description

Hi all,

I'm not a developer (also my first possible bug report) of any sort but i hope I am providing enough detail for this post to be helpful.


Motherboard: SuperMicro A2SDi-TP8F | https://www.supermicro.com/products/motherboard/atom/A2SDi-TP8F.cfm

PF Sense Version: pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-latest.img

PF Sense Download Date: 07/04/2018

Nics: 4x 1Gbe (Pro 1000) | Quad LAN with Intel Ethernet Controller I350-AM4

Nics: 4x10Gbe (Pro/10Gbe) | C3000 SoC 2 10GBaseT, 2 10Gb SFP+

Issue:

When attempting to setup interfaces on PFSense 2.4.4 using autodetection none of the 10Gbe interfaces are ever detected to have a link up so autodetection doesnt seem to work.

Doing the same thing with the 1gbe interfaces works fine just like normal.

Steps I am doing to produce bug:

  1. select option 1 for assign interfaces
  2. select n to assign vlans first
  3. select a to use interface autodetection
  4. plug in a ethernet cable into one of the 10Gbe copper ports wait for light to come up on port
  5. select enter to use auto-detection at which point it says "No link-up detected"

I also have a screenshot below that shows this process since the supermicro board has ipmi.

Not sure if this qualifies as a bug or not and i know the c3858 is fairly new which is why i needed to use 2.4.4 since it has driver support for this version of free bsd.

Hopefully this is a helpful bug report. Please let me know if I should submit it elsewhere.

Thank you


Picture Link: https://imgur.com/K7DKxrD

Orignal Post: https://forum.netgate.com/topic/132529/2-4-4-possible-bug-with-intel-c3858-and-interface-auto-detection-on-10gb-interfaces/2

link detection on supermicro.png (149 KB) link detection on supermicro.png Kevin Boatswain, 07/04/2018 09:31 PM

History

#1 Updated by Clinton Cory over 1 year ago

I have a SuperMicro box with the same specs on-hand. Will attempt to replicate and debug.

#2 Updated by Jim Thompson over 1 year ago

  • Assignee set to Clinton Cory

#3 Updated by Clinton Cory over 1 year ago

  • Status changed from New to Assigned

Installed 2.4.4 CE build: pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-20180705-0739.img

ifconfig outputs the following interfaces:
igb0-igb3
ix0-ix3

By default I see WAN (igb0) and LAN (igb1).

I was able to replicate the issue reported:

Enter the Optional 1 interface name or 'a' for auto-detection
(igb2 igb3 ix0 ix1 ix2 ix3 a or nothing if finished): a

Connect the Optional 1 interface now and make sure that the link is up.
Then press ENTER to continue.

No link-up detected.

Enter the Optional 1 interface name or 'a' for auto-detection
(igb2 igb3 ix0 ix1 ix2 ix3 a or nothing if finished):

The above with was ix0 and ix1 (TenG ethernet). Same issue occurs with 10G SFP+ - even with a loopback between ix2 and ix3. No link light appears when 10G SFP+ is connected but I do see link light on the two 10G ethernet ports when connected, despite not auto-detecting.

I also noticed igb2 and igb3 exhibit this problem. If I 'up' the igb interface via ifconfig, I'm able to get link detection. If I assign an interface and enable the interface, I'm able to get link detection when re-assigning interfaces from the shell menu (even with the ix ports). I don't see the interface state logged unless the interface is up or enabled at some point. Looking at dmesg during boot with igb0 assigned to WAN and ix0 assigned to LAN (both enabled), I can see the interface come up:
igb0: link state changed to UP
pflog0: promiscuous mode enabled
igb0: link state changed to DOWN
igb0: link state changed to UP
ix0: link state changed to UP

If I unplug ix0 and try to re-assign with link detection, it detects ix0 but is still not able to detect ix1.
I also noticed igb2 and igb3 would show active despite no media connected at points during the testing.

I'd like to test out the 2.4.4 factory snapshot next to see if the same symptoms occur there.

#4 Updated by Clinton Cory over 1 year ago

Spent some more time looking into this with the latest CE snapshot from today. This time I installed it on a XG-1537 to see if there are any issues on that platform.

I saw the same issue on the XG-1537....in general the igb interfaces worked okay but the ix interfaces were problematic.

I believe the issue here is the ix interfaces are in a 'down' state and will not display link status unless the interface is 'up'. The igb interfaces will report link status even in a 'down' state.

Example:
ifconfig ix0 down
connect a link to ix0, link light will appear
ifconfig ix0
status: no carrier
ifconfig ix0 up
status: active

ifconfig igb0 down
connect a link to igb0, link light will appear
ifconfig igb0
status: active

If I 'up' an ix interface then try to perform an interface assignment with autoselect it works. Luiz made some comments that may be related to that here:
https://redmine.pfsense.org/issues/7763

But it does not appear to be limited to SFP+ ports.

#5 Updated by Clinton Cory over 1 year ago

  • Status changed from Assigned to Ready To Test

2.4.4 pfSense installer will enable OPT IX interfaces by default rather than just assigning the IX interface to OPT*

Next snapshot should include this change. Will test once it's ready.

#6 Updated by Clinton Cory over 1 year ago

  • Status changed from Ready To Test to Closed

This appears to be working now.

#7 Updated by Kevin Boatswain over 1 year ago

Clinton Cory wrote:

This appears to be working now.

Thank you for helping get this Ironed out for the new platform and chipset.

Also available in: Atom PDF