Project

General

Profile

Bug #8722

ACB issue after upgreade 2.4.4-DEV 20180728 up to current snap

Added by Azamat Khakimyanov about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
07/31/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

After upgrade 2.4.4-DEV from 20180728 up to 20180731 I caught "PHP Fatal error: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31) in /etc/inc/acb.inc on line 63"

I had ACB installed when I used 2.4.3_p1 and I didn't upgrade ACB manually - just made system updrade (from 2.4.3_p1 up to 2.4.4-DEV and then from time to time up to current 2.4.4-snap).
Today I caught this PHP crash. ACB was removed during upgrade process.

My system didn't start at first boot, but works OK after reboot.

config.xml (100 KB) config.xml Azamat Khakimyanov, 07/31/2018 09:46 AM

History

#1 Updated by Azamat Khakimyanov about 1 year ago

I attached config.xml which was made by ACB yesterday (before upgrade)

#2 Updated by Azamat Khakimyanov about 1 year ago

the same error after I upgraded 2.4.2 -> 2.4.3_p1 -> 2.4.4 current snap
PHP Errors:
[31-Jul-2018 15:01:30 Etc/UTC] PHP Fatal error: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31) in /etc/inc/acb.inc on line 63
and system wouldn't like to boot. After reboot it works OK. (

#3 Updated by Steve Beaver about 1 year ago

Remove the ACB package

#4 Updated by Jim Pingle about 1 year ago

If removing the ACB package is a requirement to upgrade, we should fix pfSense-upgrade so it gets removed automatically. I think we've done this for some cases but perhaps not all. I upgraded one here and it removed the package on upgrade, but apparently not all scenarios are covered.

#5 Updated by Jim Pingle about 1 year ago

  • Category set to Upgrade
  • Target version set to 2.4.4
  • Affected Architecture set to All

#6 Updated by Steve Beaver about 1 year ago

  • Category deleted (Upgrade)
  • Target version deleted (2.4.4)
  • Affected Architecture deleted (All)

Since the ACB package is no longer in the repository, it should have been removed automatically

#7 Updated by Jim Pingle about 1 year ago

It is being removed, but it's being removed too late for it to avoid the ACB conflict

Fatal error: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31) in /etc/inc/acb.inc on line 63
PHP ERROR: Type: 64, File: /etc/inc/acb.inc, Line: 63, Message: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31)pkg-static: DEINSTALL script failed
Saving updated package information...

Fatal error: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31) in /etc/inc/acb.inc on line 63
PHP ERROR: Type: 64, File: /etc/inc/acb.inc, Line: 63, Message: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31)pkg-static: POST-INSTALL script failed
[6/6] Upgrading pfSense-pkg-System_Patches from 1.1.8 to 1.1.10...
[6/6] Extracting pfSense-pkg-System_Patches-1.1.10: ......... done
Removing System_Patches components...
Menu items... done.

Fatal error: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31) in /etc/inc/acb.inc on line 63
PHP ERROR: Type: 64, File: /etc/inc/acb.inc, Line: 63, Message: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31)pkg-static: DEINSTALL script failed
Saving updated package information...

Fatal error: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31) in /etc/inc/acb.inc on line 63
PHP ERROR: Type: 64, File: /etc/inc/acb.inc, Line: 63, Message: Cannot redeclare acb_enabled() (previously declared in /usr/local/pkg/autoconfigbackup.inc:31)pkg-static: POST-INSTALL script failed
>>> Scheduling package pfSense-pkg-AutoConfigBackup for removal... 
>>> Scheduling package pfSense-pkg-aws-wizard for removal... 
>>> Removing unnecessary packages... done.
>>> Cleanup pkg cache... done.
pfSense 2.4.4-DEVELOPMENT amd64 Mon Aug 06 15:04:03 EDT 2018
Bootup complete

At which point it landed me at an Amnesiac login. I logged in and checked, but ACB was removed by that point. I had to issue a manual reboot and then it was OK.

#8 Updated by Renato Botelho about 1 year ago

  • Category set to Upgrade
  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.4.4
  • % Done changed from 0 to 100

I've reworked pfSense-upgrade to remove unexistent ports in the first stage of upgrade process, before reboot. With that change, ACB will be removed earlier and the conflict won't happen.

#9 Updated by Renato Botelho about 1 year ago

  • Status changed from Feedback to Resolved

Confirmed working after upgrade 2.4.3 with pfSense-AutoConfigBackup installed to 2.4.4

Installed packages to be UPGRADED:
    pfSense-kernel-pfSense: 2.4.3 -> 2.4.4.a.20180807.1232 [pfSense-core]

Number of packages to be upgraded: 1

The process will require 24 MiB more space.
[1/1] Upgrading pfSense-kernel-pfSense from 2.4.3 to 2.4.4.a.20180807.1232...
[1/1] Extracting pfSense-kernel-pfSense-2.4.4.a.20180807.1232: .......... done
===> Keeping a copy of current kernel in /boot/kernel.old
>>> Scheduling package pfSense-pkg-AutoConfigBackup for removal... 
>>> Removing unnecessary packages... done.
Upgrade is complete.  Rebooting in 10 seconds.
Success

Also available in: Atom PDF