Project

General

Profile

Bug #882

IP aliases should not sync

Added by Chris Buechler almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Virtual IPs
Target version:
Start date:
09/08/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

IP alias VIPs should not sync to the secondary

Associated revisions

Revision 7eab3309 (diff)
Added by Pierre POMES almost 9 years ago

Do not synchronize ip alias. Ticket #882

Revision 8a98ce81 (diff)
Added by Pierre POMES almost 9 years ago

ipalias type should be handled in backup_vip_config_section. Remove useless code which copies vip section before call to backup_vip_config_section. Ticket #882

History

#1 Updated by Pierre POMES almost 9 years ago

  • Status changed from New to Feedback
  • Assignee set to Pierre POMES
  • % Done changed from 0 to 100

The line to prevent synchronization (as for "proxyarp") was missing, probably because "ipalias" VIP type was added in pfSense 2.0.

#2 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

#3 Updated by Thiago Witt almost 9 years ago

Hi, I've just tested it with the latest snapshot and it seems the problem remains.

Looking at the source, I think I found the problem, well at least it seems to do the trick here with no side-effects:

--- /tmp/rc.filter_synchronize 2010-10-18 16:56:50.000000000 0200
++ /etc/rc.filter_synchronize 2010-10-18 16:52:24.000000000 -0200
@ -51,7 +51,7 @
global $config;
$new_section = &$config['virtualip'];
foreach($new_section['vip'] as $section) {
if($section['mode'] "proxyarp") {
if($section['mode'] "proxyarp" || $section['mode'] == "ipalias") {
unset($section);
}

I hope it helps.

#4 Updated by Pierre POMES almost 9 years ago

  • Status changed from Resolved to Assigned
  • % Done changed from 100 to 0

Thanks for the report. I will doublecheck.

Pierre

#5 Updated by Pierre POMES almost 9 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

Hi Thiago,

A new fix hax been commited. Can you please try again ?

Thanks again,
Pierre

#6 Updated by Thiago Witt over 8 years ago

Hi Pierre,

I just update both my systems with gitsync and now it no longer syncs the aliases, so that's ok.

Now the problem is that I also want to have an alias VIP only on the slave, but when I create or modify a VIP on the master it deletes the extra aliases created on the slave.

What I'm trying to do is to have 2 CARP VIPs on the same interface, but each using a different subnet, that's why I need an alias on each system, so I can create the second CARP VIP, otherwise it won't let me.

Should I open a new ticket?

Thanks,
Thiago

#7 Updated by Pierre POMES over 8 years ago

  • Status changed from Feedback to Resolved

Hi Thiago,

Ok for the new ticket. I will put this one to resolved since the initial report is now ok.

Thanks,
Pierre

Also available in: Atom PDF