Project

General

Profile

Bug #8833

haproxy getarraybyref error

Added by Chris Macmahon 11 months ago. Updated 5 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
haproxy
Target version:
-
Start date:
08/25/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

On update to latest snapshot HA Proxy service fails to start.

Fatal error: Cannot redeclare getarraybyref() (previously declared in /etc/inc/pfsense-utils.inc:3461) in /usr/local/pkg/haproxy/haproxy_utils.inc on line 105

PHP ERROR: Type: 1, File: /usr/local/pkg/haproxy/haproxy_utils.inc, Line: 105, Message: Cannot redeclare getarraybyref() (previously declared in /etc/inc/pfsense-utils.inc:3461)

cat /etc/version
2.4.4-DEVELOPMENT

cat /etc/version.buildtime
Fri Aug 24 11:44:17 EDT 2018

History

#1 Updated by Pi Ba 11 months ago

fix kinda pending.. but discussion raised is delaying it being pulled.
https://github.com/pfsense/FreeBSD-ports/pull/555#discussion_r212271252

#2 Updated by Pi Ba 11 months ago

Should be fixed with current 0.59_11 version. If not please let me know the exact error you get and when that happens.

#3 Updated by Jared Dillard 5 months ago

  • Category set to haproxy

Also available in: Atom PDF