Project

General

Profile

Actions

Bug #8845

closed
CL RB

Recompile PHP with a larger value of FD_SETSIZE.

Bug #8845: Recompile PHP with a larger value of FD_SETSIZE.

Added by Chris Linstruth about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
PHP Interpreter
Target version:
Start date:
08/28/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4
Affected Architecture:

Description

Crash report begins. Anonymous machine information:

amd64
11.2-RELEASE-p2
FreeBSD 11.2-RELEASE-p2 #72 9d6b703bf03(factory-RELENG_2_4_4): Sun Aug 26 11:56:23 EDT 2018 root@buildbot3:/builder/crossbuild-master/obj/amd64/rdiCdX3r/builder/crossbuild-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[27-Aug-2018 17:44:52 Etc/UTC] PHP Warning: stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 1024, but you have descriptors numbered at least as high as 1282.
--enable-fd-setsize=2048 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 154

Seeing on SG-5100.

Updated by Anonymous about 8 years ago Actions #1

  • Category set to Administrivia
  • Assignee set to Renato Botelho

Updated by Anonymous about 8 years ago Actions #2

  • Category changed from Administrivia to PHP Interpreter

RB Updated by Renato Botelho about 8 years ago Actions #3

  • Status changed from New to In Progress

RB Updated by Renato Botelho about 8 years ago Actions #4

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

Applied in changeset commit:4f03ad7a36b6c2f9060f059f167a491b06739acf.

Updated by Anonymous about 8 years ago Actions #5

On 2.4.4.a.20180829.1926,

Shell Output - php -i | grep fd-setsize

Configure Command =>  './configure'  '--with-layout=GNU' '--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all' '--enable-libxml' '--enable-mysqlnd' '--with-libxml-dir=/usr/local' '--with-pcre-regex=/usr/local' '--with-password-argon2=/usr/local' '--program-prefix=' '--enable-fd-setsize=2048' '--enable-fpm' '--with-fpm-user=www' '--with-fpm-group=www' '--enable-embed' '--enable-dtrace' '--prefix=/usr/local' '--localstatedir=/var' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=amd64-portbld-freebsd11.2' 'build_alias=amd64-portbld-freebsd11.2' 'CFLAGS=-O2 -pipe -fstack-protector -fno-strict-aliasing' 'CPPFLAGS=' 'CPP=cpp'

'--enable-fd-setsize=2048'

Looks good.

Updated by Anonymous about 8 years ago Actions #6

  • Status changed from Feedback to Resolved

RS Updated by Rajil Saraswat about 8 years ago Actions #7

I am seeing the same crash on pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-20180904-1004.img running on Supermicro C3558 system,

Crash report begins.  Anonymous machine information:

amd64
11.2-RELEASE-p2
FreeBSD 11.2-RELEASE-p2 #109 b0703dcab3c(RELENG_2_4_4): Tue Sep  4 10:05:18 EDT 2018     root@buildbot3:/builder/crossbuild-ce-master/obj/amd64/FWJoMRHc/builder/crossbuild-ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[13-Sep-2018 17:49:37 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:50:37 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:51:37 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:52:38 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:53:38 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:54:38 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:55:38 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:56:38 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150
[13-Sep-2018 17:57:38 Asia/Kolkata] PHP Warning:  stream_select(): You MUST recompile PHP with a larger value of FD_SETSIZE.
It is set to 2048, but you have descriptors numbered at least as high as 2161.
 --enable-fd-setsize=3072 is recommended, but you may want to set it
to equal the maximum number of open files supported by your system,
in order to avoid seeing this error again at a later date. in /etc/inc/pkg-utils.inc on line 150

No FreeBSD crash data found.

RB Updated by Renato Botelho about 8 years ago Actions #8

Rajil Saraswat wrote:

I am seeing the same crash on pfSense-CE-memstick-2.4.4-DEVELOPMENT-amd64-20180904-1004.img running on Supermicro C3558 system,

[...]

Increased to 3172 on #8895

Actions

Also available in: Atom