Project

General

Profile

Bug #8937

LAGG shows wrong ether address

Added by Flole Systems over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
09/24/2018
Due date:
% Done:

100%

Estimated time:
1.00 h
Plus Target Version:
Release Notes:
Default
Affected Version:
2.4.4
Affected Architecture:

Description

I am using a LACP Bond over 4 Interfaces. When I look into the LAGG configuration, I am seeing the ether instead of hwether address. It is the same on all Interfaces, that makes it impossible to seperate between all those interfaces. I request that hwether is being shown in there instead.

Associated revisions

Revision ede4faa7 (diff)
Added by Renato Botelho over 2 years ago

Fix #8937: Show hwaddr for LAGG members

Revision 6b0ef045 (diff)
Added by Renato Botelho over 2 years ago

Fix #8937: Show hwaddr for LAGG members

History

#1 Updated by Steve Beaver over 2 years ago

  • Target version changed from 2.4.4-GS to 2.4.4-p1

#2 Updated by Steve Beaver over 2 years ago

  • Status changed from New to Feedback
  • Priority changed from High to Normal

Please provide some more details of this issue. It is not clear from the description what the problem is. Where do you "see" the wrong address?

#3 Updated by Flole Systems over 2 years ago

Create a new LAGG with some interfaces and save it. Once thats done, edit that LAGG and on everything interface name that you can select to add or remove it, in the parentheses they show the MAC if the LAGG, which is not helpful at all because it's all the same then. It should show the real MAC of the interface instead.

#4 Updated by Steve Beaver over 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee set to Steve Beaver

#5 Updated by Steve Beaver over 2 years ago

  • Status changed from In Progress to New

From a quick look at utils.inc:get_interface_list() this would require the addition of some logic;

if $IFACE is member of LAGG group
MAC = exec ( ifconfig $IFACE | grep hwaddr| awk '{print $2}' )
ELSE
...

Not sure the ugliness of that is worth it

Looking at alternatives now

#6 Updated by Renato Botelho over 2 years ago

  • Status changed from New to In Progress
  • Assignee changed from Steve Beaver to Renato Botelho

#7 Updated by Renato Botelho over 2 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

#8 Updated by Anonymous over 2 years ago

  • Status changed from Feedback to Resolved

Tested on 2.4.5.a.20181120.0754 gitsync'd to master, works as expected. Lists ether and hwaddr.

Also available in: Atom PDF