Project

General

Profile

Bug #8950

IGMPProxy broken after 2.4.4 upgrade

Added by Tim Balmer over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
IGMP Proxy
Target version:
-
Start date:
09/25/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
amd64

Description

After upgrade from 2.4.3-p1 to 2.4.4 IGMPProxy (which is upgraded during the 2.4.4 upgrade) seems to be broken. When running in debug mode it just looks like all packets from my downstream interface are completely ignored by igmpproxy. As a result of that the IPTV streams are of course stopping after about a second.

My configfile:

##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave
phyint vmx2 upstream ratelimit 0 threshold 1
altnet 213.75.0.0/16
altnet 10.0.0.0/8

phyint vmx8 downstream ratelimit 0 threshold 1
altnet 192.168.8.0/24

phyint pppoe0 disabled
phyint vmx0 disabled
phyint vmx5 disabled
phyint vmx7 disabled
phyint vmx1 disabled
phyint vmx4 disabled
phyint vmx6 disabled

IGMPProxy debug output while IGMP packets are coming in at the vmx2 interface:

[2.4.4-RELEASE][admin@fw-01]/root: igmpproxy -d -vv /var/etc/igmpproxy.conf
Searching for config file at '/var/etc/igmpproxy.conf'
Config: Quick leave mode enabled.
Config: Got a phyint token.
Config: IF: Config for interface vmx2.
Config: IF: Got upstream token.
Config: IF: Got ratelimit token '0'.
Config: IF: Got threshold token '1'.
Config: IF: Got altnet token 213.75.0.0/16.
Config: IF: Altnet: Parsed altnet to 213.75/16.
Config: IF: Got altnet token 10.0.0.0/8.
Config: IF: Altnet: Parsed altnet to 10/8.
IF name : vmx2
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 1
Allowednet ptr : e21000
Config: Got a phyint token.
Config: IF: Config for interface vmx8.
Config: IF: Got downstream token.
Config: IF: Got ratelimit token '0'.
Config: IF: Got threshold token '1'.
Config: IF: Got altnet token 192.168.8.0/24.
Config: IF: Altnet: Parsed altnet to 192.168.8/24.
IF name : vmx8
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 2
Allowednet ptr : e21020
Config: Got a phyint token.
Config: IF: Config for interface pppoe0.
Config: IF: Got disabled token.
IF name : pppoe0
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
Config: Got a phyint token.
Config: IF: Config for interface vmx0.
Config: IF: Got disabled token.
IF name : vmx0
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
Config: Got a phyint token.
Config: IF: Config for interface vmx5.
Config: IF: Got disabled token.
IF name : vmx5
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
Config: Got a phyint token.
Config: IF: Config for interface vmx7.
Config: IF: Got disabled token.
IF name : vmx7
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
Config: Got a phyint token.
Config: IF: Config for interface vmx1.
Config: IF: Got disabled token.
IF name : vmx1
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
Config: Got a phyint token.
Config: IF: Config for interface vmx4.
Config: IF: Got disabled token.
IF name : vmx4
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
Config: Got a phyint token.
Config: IF: Config for interface vmx6.
Config: IF: Got disabled token.
IF name : vmx6
Next ptr : 0
Ratelimit : 0
Threshold : 1
State : 0
Allowednet ptr : 0
buildIfVc: Interface vmx0 Addr: 192.168.1.1, Flags: 0xffff8843, Network: 192.168.1/24
buildIfVc: Interface vmx1 Addr: 192.168.4.1, Flags: 0xffff8843, Network: 192.168.4/24
buildIfVc: Interface vmx2 Addr: 10.236.173.54, Flags: 0xffff8843, Network: 10.236.172/22
buildIfVc: Interface vmx4 Addr: 192.168.5.1, Flags: 0xffff8843, Network: 192.168.5/24
buildIfVc: Interface vmx5 Addr: 192.168.2.1, Flags: 0xffff8843, Network: 192.168.2/24
buildIfVc: Interface vmx6 Addr: 192.168.7.1, Flags: 0xffff8843, Network: 192.168.7/24
buildIfVc: Interface vmx7 Addr: 192.168.6.1, Flags: 0xffff8843, Network: 192.168.6/24
Found config for vmx0
Found config for vmx1
Found config for vmx2
Found config for vmx4
Found config for vmx5
Found config for vmx6
Found config for vmx7
Found upstrem IF #0, will assing as upstream Vif 9
adding VIF, Ix 0 Fl 0x0 IP 0x36adec0a vmx2, Threshold: 1, Ratelimit: 0
        Network for [vmx2] : 10.236.172/22
        Network for [vmx2] : 213.75/16
        Network for [vmx2] : 10/8
Got 262144 byte buffer size in 0 iterations
Created timeout 1 (#0) - delay 10 secs
(Id:1, Time:10)
Created timeout 2 (#1) - delay 21 secs
(Id:1, Time:10)
(Id:2, Time:21)
About to call timeout 1 (#0)
Aging routes in table.

Current routing table (Age active routes):
-----------------------------------------------------
No routes in table...
-----------------------------------------------------
About to call timeout 2 (#0)
Created timeout 3 (#0) - delay 10 secs
(Id:3, Time:10)
Created timeout 4 (#1) - delay 21 secs
(Id:3, Time:10)
(Id:4, Time:21)
About to call timeout 3 (#0)
Aging routes in table.

Current routing table (Age active routes):
-----------------------------------------------------
No routes in table...
-----------------------------------------------------
About to call timeout 4 (#0)
Created timeout 5 (#0) - delay 10 secs
(Id:5, Time:10)
Created timeout 6 (#1) - delay 115 secs
(Id:5, Time:10)
(Id:6, Time:115)
About to call timeout 5 (#0)
Aging routes in table.

Current routing table (Age active routes):
-----------------------------------------------------
No routes in table...
-----------------------------------------------------
^Cselect() failure; Errno(4): Interrupted system call
Got a interrupt signal. Exiting.
clean handler called
All routes removed. Routing table is empty.
Shutdown complete....

When I manually copied the igmpproxy binary from my previous 2.4.3-p1 installation to /usr/local/sbin/igmpproxy on the 2.4.4 installation it is working fine again.

History

#1 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Duplicate
  • Target version deleted (2.4.4-GS)

Duplicate of #8935

Also available in: Atom PDF