Project

General

Profile

Bug #9148

PPPoE over a VLAN fails to reconnect.

Added by Steve Wheeler almost 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
PPP Interfaces
Target version:
Start date:
11/22/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

In some situations PPPoE fails to reconnect after an upstream outage or making a change locally. The system file logs:

Nov 21 16:45:32 pfsense ppp: [wan_link0] Link: reconnection attempt 4
Nov 21 16:45:32 pfsense ppp: [wan_link0] PPPoE: can't connect "[1b]:"->"mpd17126-0" and "[4e]:"->"left": No such file or directory
Nov 21 16:45:32 pfsense ppp: [wan_link0] can't remove hook mpd17126-0 from node "[1b]:": No such file or directory
Nov 21 16:45:32 pfsense ppp: [wan_link0] Link: DOWN event
Nov 21 16:45:32 pfsense ppp: [wan_link0] LCP: Down event
Nov 21 16:45:32 pfsense ppp: [wan_link0] Link: reconnection attempt 5 in 4 seconds

This appears to primarily affect PPPoE connections running over a VLAN but there have been reports of it in general.

It brings down all PPPoE connections when this happens regardless of where the local change was made.

History

#1 Updated by Rai Wol almost 2 years ago

I can confirm. After making a change to one of the interfaces and hit apply, my pppoe connection over vlan 6 disconnects and doesnt reconnect automatically. When I goto Status->Interfaces and hit Connect sometimes it succeeds but most of the time it fails and I need to reboot the firewall to get pppoe connected again.

#2 Updated by net blues almost 2 years ago

Just adding a new vlan also brings down all pppoe interfaces, with the same exact error.

#3 Updated by Luiz Souza almost 2 years ago

  • Target version set to 48

#4 Updated by Luiz Souza almost 2 years ago

  • Assignee set to Luiz Souza

#5 Updated by Steve Wheeler almost 2 years ago

There looks to be a good chance this is resolved by this:

https://github.com/pfsense/pfsense/commit/433a8e71f3b68c39634e11b62d8bf3d9e8ec878c.patch

Applying that prevents the issues I was seeing when interface changes are made. Waiting to see if it corrects issues caused by the link failing.

#6 Updated by Rai Wol almost 2 years ago

Steve Wheeler wrote:

There looks to be a good chance this is resolved by this:

https://github.com/pfsense/pfsense/commit/433a8e71f3b68c39634e11b62d8bf3d9e8ec878c.patch

Applying that prevents the issues I was seeing when interface changes are made. Waiting to see if it corrects issues caused by the link failing.

This fixed it!

#7 Updated by net blues almost 2 years ago

I can confirm this fixes the issue.
I also created a failure upstream bringing down one ppp interface. The rest remained up, as expected.

#8 Updated by Steve Wheeler over 1 year ago

  • Status changed from New to Feedback

This should be fixed in 2.4.4p2

#9 Updated by Jim Pingle over 1 year ago

  • Target version changed from 48 to 2.5.0

#10 Updated by gek Johnson over 1 year ago

Steve Wheeler wrote:

In some situations PPPoE fails to reconnect after an upstream outage or making a change locally. The system file logs:
[...]

This appears to primarily affect PPPoE connections running over a VLAN but there have been reports of it in general.

It brings down all PPPoE connections when this happens regardless of where the local change was made.

It's reproducing on 2.4.4-RELEASE-p3.
I did try clear 2.4.4-RELEASE-p3 and also 2.4.4-RELEASE-p3+ patch above. Nothing helped.

#11 Updated by Me Ichthys about 1 year ago

gek Johnson wrote:

It's reproducing on 2.4.4-RELEASE-p3.

I'm also seeing the issue again in 2.4.4-RELEASE-p3.
Generally I need to reboot the pfSense box, but sometimes restarting the PPOE WAN interface will work.

It it helps, i'm running pfSense virtualized and on a Proxmox host. I'm using VLANS in my network, but not in pfSense. All my VLAN configuration is done in Proxmox and on my managed switch.

#12 Updated by Jim Pingle 10 months ago

  • Status changed from Feedback to Closed

I still can't reproduce a problem here. I have PPPoE setup with a VLAN parent and if I take down the server and bring it back up, the client reconnects immediately.

Either the problem has been solved, or there is some other issue specific to your environment or configuration that has not yet been identified. In anyone still has a problem on 2.5.0 snapshots or later, start a forum thread and include as much information as possible about your setup, interfaces, PPP logs, etc.

Also available in: Atom PDF