Project

General

Profile

Bug #9218

SNMP sysDescr does not display hostname and patch version

Added by d j over 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Category:
SNMP
Target version:
Start date:
12/21/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Hi,

With this command

snmpget  -c public -v1 hostname iso.3.6.1.2.1.1.1.0
iso.3.6.1.2.1.1.1.0 = STRING: "pfSense  2.4.4-RELEASE pfSense FreeBSD 11.2-RELEASE-p4 arm

hostname is missing and the exact release is 2.4.4-RELEASE-p1 like dashboard.
It could be useful to have exact patch to find which remote system need updating.
Thanks in advance

Associated revisions

Revision 1ef5b31b (diff)
Added by d j 6 months ago

Bug #9218

(cherry picked from commit adc6ddbdbbb465fd3cb58d931465ac93b1fdedb6)

History

#2 Updated by Renato Botelho 10 months ago

  • Category set to SNMP
  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0
  • % Done changed from 0 to 100
  • Affected Version set to All

PR has been merged. Thanks!

#3 Updated by Chris Linstruth 7 months ago

$ snmpget -c public -v1 172.25.228.13 iso.3.6.1.2.1.1.1.0
SNMPv2-MIB::sysDescr.0 = STRING: pfSense pfSense-c.lab.example.com 2.5.0-DEVELOPMENT pfSense FreeBSD 12.0-RELEASE-p8 amd64

#4 Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Resolved

#5 Updated by Jim Pingle 4 months ago

  • Target version changed from 2.5.0 to 2.4.5

#6 Updated by Jim Pingle 4 months ago

  • Status changed from Resolved to Feedback

Needs checked and/or tested again on 2.4.5 snapshots

#7 Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved

Works as intended now on 2.4.5 and 2.5.0, all the expected information is present. For good measure I applied it against 2.4.4-p3 and it did show 2.4.4-RELEASE-p3

Also available in: Atom PDF