Project

General

Profile

Bug #9264

Disabling "IPv6 over IPv4 Tunneling" breaks config

Added by Chris Collins 5 months ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
01/09/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4_1
Affected Architecture:
amd64

Description

Steps that may possibly reproduce.

1 - enable "IPv6 over IPv4 Tunneling" and set an ip address in the "ipv4 address of tunnel peer field"
2 - save and apply
3 - disable "IPv6 over IPv4 Tunneling" and empty the "ipv4 address of tunnel peer field"

This error pops up.

"Fatal error: Uncaught Error: Cannot unset string offsets in /usr/local/www/system_advanced_network.php:112 Stack trace: #0 {main} thrown in /usr/local/www/system_advanced_network.php on line 112 PHP ERROR: Type: 1, File: /usr/local/www/system_advanced_network.php, Line: 112, Message: Uncaught Error: Cannot unset string offsets in /usr/local/www/system_advanced_network.php:112 Stack trace: #0 {main} thrown"

If page is reloaded, the box is unticked, there seems to be a value of "1" left as the "ipv4 address of tunnel field" config.

The problem is even if its successfully disabled, now changing "any" setting on that networking page will throw up the php error, so unit is damaged.

I am reporting the bug, but also a request is if there is a way to now manually fix the config. So I am not resorting to setting up the unit from scratch to clear the error.

Associated revisions

Revision 3fcf5ad7 (diff)
Added by Jim Pingle 4 months ago

Fix saving IPv6 over IPv4 tunneling NAT setting. Fixes #9264

Revision 4ec6eee8 (diff)
Added by Jim Pingle 4 months ago

Fix saving IPv6 over IPv4 tunneling NAT setting. Fixes #9264

(cherry picked from commit 3fcf5ad71216922921801d85d063d360fde5566f)

Revision 5345b254 (diff)
Added by Jim Pingle 4 months ago

Init array for 6o4 tunneling Fixes #9264

Revision 5c8aaa20 (diff)
Added by Jim Pingle 4 months ago

Init array for 6o4 tunneling Fixes #9264

(cherry picked from commit 5345b25405101eba3112c1d5daef99bd3b308533)

History

#1 Updated by Chris Collins 5 months ago

missed step 4 which is hit save and apply again.

#2 Updated by Chris Collins 5 months ago

Raising urgency of bug, as it seems it does actually prevent toggling other settings on the networking page. Until I fix the config my settings on that page are now locked in place, unless I enable the "ip[v6 over ipv4 tunneling again".

#3 Updated by Chris Collins 5 months ago

lower urgency now.

I fixed my local config with viconfig.

The setting that got stick is 'ipvnat'

It looked like this in the config

<ipv6nat>1</ipv6nat>

I removed the 1 and its normal again.

So if you follow the steps provided it should get in that stuck state.

#4 Updated by Jim Pingle 4 months ago

  • Assignee set to Jim Pingle
  • Target version set to 48

#5 Updated by Jim Pingle 4 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#6 Updated by James Dekker 4 months ago

On 2.4.5.a.20190111.1435 (stock - factory default), able to reproduce the behavior.

Warning: Illegal string offset 'enable' in /usr/local/www/system_advanced_network.php on line 107 Warning: Illegal string offset 'ipaddr' in /usr/local/www/system_advanced_network.php on line 108

#7 Updated by Danilo Zrenjanin 4 months ago

Reproduced the issue on SG-5100:

2.4.4-RELEASE-p2 (amd64)
built on Wed Dec 12 14:40:29 EST 2018
FreeBSD 11.2-RELEASE-p6

and

2.4.5-DEVELOPMENT (amd64)
built on Fri Jan 11 14:35:41 EST 2019
FreeBSD 11.2-RELEASE-p8

PHP Errors:
[16-Jan-2019 17:11:55 Etc/UTC] PHP Warning:  Illegal string offset ‘enable’ in /usr/local/www/system_advanced_network.php on line 107

#8 Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Assigned

#9 Updated by Jim Pingle 4 months ago

That's a new error, not the same one. I can't reproduce that here, but I can see how it might happen. Pushed a new fix.

#10 Updated by Jim Pingle 4 months ago

  • Status changed from Assigned to Feedback

#11 Updated by Danilo Zrenjanin 3 months ago

  • Status changed from Feedback to Resolved

Tested on:

2.4.5-DEVELOPMENT (amd64)
built on Wed Feb 13 06:09:38 EST 2019
FreeBSD 11.2-RELEASE-p8

No warnings, no errors. Looks good now.

#12 Updated by Jim Pingle 2 months ago

  • Target version changed from 48 to 2.5.0

#13 Updated by Jim Pingle 13 days ago

  • Target version changed from 2.5.0 to 2.4.4-p3

#14 Updated by Jim Pingle 13 days ago

  • Status changed from Resolved to Feedback

#15 Updated by Constantine Kormashev 11 days ago

Tried on 2.4.4-p3. I do not observe the issue.

0. set IPv6 on LAN
1. enable "IPv6 over IPv4 Tunneling" and set an ip address in the "ipv4 address of tunnel peer field"
2. save (there is not apply only save)
3. empty the "ipv4 address of tunnel peer field" and disable "IPv6 over IPv4 Tunneling" (empty and disable not vice versa, because if disable is performed, then field disappears)
4. save

Config looks fine:

Enabled

<ipv6nat>
    <enable></enable>
    <ipaddr>192.168.128.240</ipaddr>
</ipv6nat>

Disabled

<ipv6nat></ipv6nat>

#16 Updated by Jim Pingle 11 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF