Project

General

Profile

Bug #936

Bad racoon.conf generated with localid_type=address

Added by Thiago Witt over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
Start date:
10/05/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When setting up a new Phase 2 IPSEC connection in the GUI, if 'Local Network' is set to 'Address', then an invalid racoon.conf is generated with fatal error (parse error on sainfo line).

Example of generated sainfo:
sainfo address 200.123.123.123 any

It should be something like:
sainfo address 192.168.40.40 any address 200.123.123.123 any

Workaround is simple - specify Local Network type as Network and specify the local address with a /32 netmask.

Associated revisions

Revision aab78bd9 (diff)
Added by Pierre POMES over 8 years ago

Fix racoon.conf generation for localid_type=address. Ticket #936

History

#1 Updated by Pierre POMES over 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Hi Thiago,

This problem should be fixed now on the next snapshot !

Regards,
Pierre

#2 Updated by Thiago Witt over 8 years ago

Thank you Pierre, I tried with the current snapshot and the issue is fixed.

Best regards,
Thiago

#3 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF