Project

General

Profile

Bug #954

Switching to manual outbound NAT creates incorrect rule for PPTP server

Added by Erik Fonnesbeck over 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
10/13/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When switching to manual outbound NAT when the PPTP server is enabled, it does not pick up any kind of IP address from the PPTP server, so the source address ends up blank. It also specifies a /32 subnet.

Somewhat related, I seem to recall the automatic rule specifying an IP address but also only a /32 subnet last time I checked it.

Associated revisions

Revision fbd96b06 (diff)
Added by Erik Fonnesbeck over 8 years ago

Fix variable names. Ticket #954

Revision 4e12754d (diff)
Added by Jim Pingle about 8 years ago

Fix automatic and manual outbound NAT for PPTP. Fixes #954

History

#1 Updated by Erik Fonnesbeck over 8 years ago

It at least picks up an IP address now, but I'm not sure if it is the right one. It is also still using /32 for the subnet.

#2 Updated by Ermal Lu├ži over 8 years ago

  • Status changed from New to Feedback

#3 Updated by Erik Fonnesbeck over 8 years ago

Any particular reason you set this to feedback? I'm fairly sure the issue is not fully resolved by just that one commit, which is why I did not change the status. (though that is only a guess; I have not tested it to be sure that it does not resolve this)

#4 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to New
  • Priority changed from Normal to Low

Not fixed. It uses the server address rather than the client addresses.

#5 Updated by Jim Pingle about 8 years ago

The internal automatic rule is wrong as well. Regardless of how many clients you have, the outbound NAT rule it makes when set on automatic doesn't have a subnet mask, so only the first connected client gets NAT applied when trying to reach the Internet from behind the PPTP connection.

#6 Updated by Jim Pingle about 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#7 Updated by Chris Buechler almost 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF