Project

General

Profile

Bug #9548

Do not use VLANMTU flag to decide if interface supports to run VLAN

Added by Renato Botelho over 1 year ago. Updated 9 months ago.

Status:
Feedback
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
05/24/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Today there is a function called is_jumbo_capable() that detects if VLANMTU flag is supported by interface and this function is used to build the list of available parent interfaces to configure VLANs.

VLANMTU means interface can do 1500 MTU even using VLAN. Not having it is not a blocker to setup VLAN on the interface. Fix the code removing this check, but make sure only physical interfaces are being listed.

Associated revisions

Revision 08fe7601 (diff)
Added by Renato Botelho over 1 year ago

Fix #9548: Do not rely on VLANMTU flag

Do not consider VLAN capable only interfaces that have VLANMTU flag.
This flag is used to determine if that interface can do 1500 MTU even
with VLANG tag set.

History

#1 Updated by Renato Botelho over 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Chris Linstruth 9 months ago

Evaluated this but could not figure out how to test it in the negative sense. Tried to make existing NICs drop the VLAN_MTU option with -vlanmtu but no luck. Interfaces that should be available for VLANs still populate, however.

ETA: I am seeing ipsec VTI and OpenVPN interfaces available for VLAN assignment. That should probably not be the case.

#3 Updated by Jim Pingle 9 months ago

The only way to really try it is to track down a bit of hardware that didn't allow VLANs before, but does now.

But that's a pretty rare case, so it may be that so long as a variety of interfaces that worked before still work now, it may be good enough.

Also available in: Atom PDF