Project

General

Profile

Actions

Feature #9703

closed

Certificate Manager Expiration Notification

Added by DRago_Angel [InV@DER] over 2 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Certificates
Target version:
-
Start date:
08/27/2019
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:

Description

It would be great if Certificate Manager will support expiration notification option for each existing certificate in storage and use existing /system_advanced_notifications.php to send alert to Administrator.
For example:
  • global configuration: notify if certificate will expire in less then X days
  • per certificate expiration notification option:
    1. >enabled\disable notifications
    2. >overwrite global configuration: notify if certificate will expire in less then X days
Actions #1

Updated by Jim Pingle over 2 years ago

  • Status changed from New to Duplicate

Duplicate of #7332

Actions #2

Updated by DRago_Angel [InV@DER] over 2 years ago

Hi Jim, the idea is duplicate, but the task itself not.

Actions #3

Updated by Jim Pingle over 2 years ago

There is no distinction here when the feature doesn't exist. They are asking for the same thing, but in different ways, so they are still duplicates and one had to be closed.

I added a cross-reference to the other issue.

Feel free to add more notes to the remaining issue if you would like to suggest other details about the implementation.

Actions #4

Updated by DRago_Angel [InV@DER] over 2 years ago

Ok, fair.

Actions #5

Updated by Orion Poplawski about 1 year ago

I just got hit by this as well. Notification email is definitely needed. Thanks.

Actions #6

Updated by DRago_Angel [InV@DER] about 1 year ago

Orion Poplawski wrote:

I just got hit by this as well. Notification email is definitely needed. Thanks.

I can approve that this already done on pfsense 2.5 devel

Actions

Also available in: Atom PDF