Project

General

Profile

Bug #9777

DNS resolver crass possible DoS

Added by Vöggur Guðmundsson 30 days ago. Updated 28 days ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
DNS Resolver
Target version:
-
Start date:
09/20/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3-p1
Affected Architecture:

Description

Hi I am running 2.4.3-RELEASE-p1 (amd64) (FreeBSD 11.1-RELEASE-p10) and have vlan for hotspot and Register DHCP leases in the DNS Resolver ON this has been running smoothly for 2 years when someone walks inn connects his phone to the hotspot whit the hostname "Khushi1plus7Pro.." this instantly crass the DNS Resolver :) .

I assume that this can be filters in the DHCP server and/or in the DNS Resolver.
Also It me be prudent to move this option to the DHCP server settings instead DNS Resolver so one can select this option peer DHCP pool/VLAN (As I do not need this for the hotspot only office vlan)

History

#1 Updated by Manuel Piovan 28 days ago

it seems similar or the same as https://redmine.pfsense.org/issues/8054
i can't reproduce it on my 2.5.0 probably already corrected
you should update to 2.4.4-p3 asap

#2 Updated by Jim Pingle 28 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF