Project

General

Profile

Todo #9864

Set autocomplete=new-password for user/password fields in forms

Added by Jim Pingle 4 months ago. Updated about 18 hours ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
10/30/2019
Due date:
% Done:

100%

Estimated time:

Description

It looks like at least Firefox and Chrome current versions suppress autocomplete for usernames and passwords when using autocomplete="new-password" rather than off which all browsers ignore for login fields these days.

Tested on a few pages with success, so it should be more widely implemented.

Associated revisions

Revision 659a8a26 (diff)
Added by Jim Pingle 4 months ago

Set autocomplete=new-password for auth forms around the GUI. Implements #9864

Revision 7f3bc6b1 (diff)
Added by Jim Pingle 4 months ago

Set autocomplete=new-password for auth forms around the GUI. Implements #9864

(cherry picked from commit 659a8a26d12b75399063dae060fa32fa23751dbf)

History

#1 Updated by Jim Pingle 4 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Jim Pingle 3 months ago

  • Target version changed from 2.5.0 to 2.4.5

#3 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Resolved

This appears to be working as intended and it doing a nice job. Pages that were particularly annoying before (like system_advanced_misc.php) no longer attempt to auto-fill. If there are still problems with this in place, there likely isn't much if anything more we can do at this point.

Tested on 2.4.5.a.20191217.0637 (and numerous 2.5.0 snaps up to this point)

#4 Updated by Corey Boyle about 18 hours ago

I have this issue with the OpenVPN Server and Client pages always getting the Proxy username/pass autofilled.

#5 Updated by Jim Pingle about 18 hours ago

On what version? This fix has been applied on 2.4.5 and 2.5.0, and on those versions I do not see the browser attempting to auto-fill proxy or auth data on OpenVPN clients (There is no proxy field on the server).

If you are still on 2.4.4-p3, then it won't be fixed until you upgrade. If you are on 2.4.5 or 2.5.0, then your browser or a browser add-on is not respecting the fields and there isn't anything else to do here.

Also available in: Atom PDF