Project

General

Profile

Actions

Bug #10240

closed

Incorrect interface assignment after switching from PPPoE

Added by Viktor Gurov over 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
PPP Interfaces
Target version:
Start date:
02/08/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5
Affected Architecture:

Description

vtnet0 - LAN
vtnet1 - WAN

If you switch WAN interface configuration type to PPPoE
and then switch to other type, interface assignment for this interface is set to vtnet0,
both LAN and WAN interfaces assigned to vtnet0!

pfSense 2.4.5.r.20200207.1113

no such issue on 2.5.0.a.20200207.2007 (could not find a resolved issue in redmine)

Actions #1

Updated by Jim Pingle over 1 year ago

  • Category changed from Interfaces to PPP Interfaces
  • Priority changed from Normal to Low
  • Target version set to 2.5.0

There was a similar problem in the past ( #1420 ) but this doesn't seem like quite the same issue.

Most likely not a new problem or a regression worthy of holding up the release, though. You can always fix it on the interface assignments page or via the console.

Actions #2

Updated by Viktor Gurov over 1 year ago

Jim Pingle wrote:

There was a similar problem in the past ( #1420 ) but this doesn't seem like quite the same issue.

Most likely not a new problem or a regression worthy of holding up the release, though. You can always fix it on the interface assignments page or via the console.

How to reproduce:
1) Create new (OPT2) pseudo-interface (l2tp for example) and link it to OPT1 interface (vtnet2 in my case);
2) Assign it on the Interfaces / Interface Assignments page;
3) Check 'Enable' and select 'L2TP' IPv4 Configuration Type. Apply;
4) Change IPv4 Configuration Type to 'Static IP', set IP and Apply;
5) Now it is assigned to vtnet2.

Now two interfaces, OPT1 and OPT2 are assigned to vtnet2

Actions #3

Updated by Steve Beaver about 1 year ago

  • Subject changed from incorrect interface assignment after switching from PPPoE to Incorrect interface assignment after switching from PPPoE
  • Assignee set to Viktor Gurov
Actions #4

Updated by Viktor Gurov about 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Viktor Gurov about 1 year ago

  • Status changed from Feedback to New
Actions #6

Updated by Renato Botelho about 1 year ago

  • Status changed from New to Feedback

PR has been merged. Thanks!

Actions #7

Updated by Max Leighton 12 months ago

  • Status changed from Feedback to Resolved

Tested in

2.5.0-DEVELOPMENT (amd64)
built on Thu Oct 29 13:03:15 EDT 2020
FreeBSD 12.2-STABLE

Works as expected. When selecting IPv4 configuration type, there is no longer an option to select Static IPv4, DHCP, or None. I can now only choose PPP, PPPoE, PPTP, or L2TP.

Marking the ticket as resolved.

Actions

Also available in: Atom PDF