Project

General

Profile

Actions

Bug #10276

closed

NTP "No Select" does not work

Added by Christian Borchert over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
NTPD
Target version:
Start date:
02/21/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

System is using Garmin 18x LVC connected via serial port providing NEMA time and PPS.

Attached are two sets of screenshots after reach has hit 377 on all timeservers and the system is stable.

Note, regardless of "No Select" being checked, NTP still selects an external time source.


Files

a001.PNG (61.7 KB) a001.PNG time servers without "no select" Christian Borchert, 02/21/2020 09:35 PM
a002.PNG (112 KB) a002.PNG webgui status without "no select" Christian Borchert, 02/21/2020 09:35 PM
a003.PNG (91.5 KB) a003.PNG shell status without "no select" Christian Borchert, 02/21/2020 09:35 PM
b001.PNG (61.9 KB) b001.PNG time servers with "no select" Christian Borchert, 02/21/2020 09:37 PM
b002.PNG (146 KB) b002.PNG webgui status with "no select" Christian Borchert, 02/21/2020 11:17 PM
b003.png (70.8 KB) b003.png shell status with "no select" Christian Borchert, 02/21/2020 11:17 PM
config.xml (1.08 KB) config.xml contents of <ntpd></ntpd> Christian Borchert, 02/22/2020 09:48 AM
ntpd.conf (1.02 KB) ntpd.conf entire file Christian Borchert, 02/22/2020 09:48 AM
Actions #1

Updated by Viktor Gurov over 1 year ago

When you add a new server(s) on the Services / NTP / Settings page,
it does not save the values of the checkboxes flags for the first time, you need to set them again and click "save".

Fix:
https://github.com/pfsense/pfsense/pull/4201

Actions #2

Updated by Christian Borchert over 1 year ago

Viktor Gurov wrote:

When you add a new server(s) on the Services / NTP / Settings page,
it does not save the values of the checkboxes flags for the first time, you need to set them again and click "save".

Fix:
https://github.com/pfsense/pfsense/pull/4201

This is a different bug.

Even after selecting the "No Select" checkbox (a second time and saving), the servers are still selected (in the subroutine, but are shown as "no select" in the webgui).
The checkbox seems to not work with pools.

Actions #3

Updated by Viktor Gurov over 1 year ago

Christian Borchert wrote:

Even after selecting the "No Select" checkbox (a second time and saving), the servers are still selected (in the subroutine, but are shown as "no select" in the webgui).
The checkbox seems to not work with pools.

Can you attach /var/etc/ntpd.conf, and content of <ntpd></ntpd> from /cf/conf/config.xml, please?

Actions #4

Updated by Christian Borchert over 1 year ago

Viktor Gurov wrote:

Can you attach /var/etc/ntpd.conf, and content of <ntpd></ntpd> from /cf/conf/config.xml, please?

Sure thing - find attached

Actions #5

Updated by Manuel Piovan over 1 year ago

that is normal behavior,not a bug, from the man page
noselect only work for "server" and "peer" not for "pool"

Actions #6

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Not a Bug
Actions #7

Updated by Jim Pingle over 1 year ago

  • Status changed from Not a Bug to Pull Request Review
Actions #8

Updated by Christian Borchert over 1 year ago

Manuel Piovan wrote:

that is normal behavior,not a bug, from the man page
noselect only work for "server" and "peer" not for "pool"

If this is correct - then should the "No Select" option be disabled/greyed out when "Pool" option is selected in the webgui?

Actions #9

Updated by Renato Botelho over 1 year ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0
  • % Done changed from 0 to 100

PR has been merged. Thanks!

Actions #10

Updated by Viktor Gurov over 1 year ago

  • Status changed from Feedback to Resolved

works as expected on 2.5.0.a.20200324.1145

Actions

Also available in: Atom PDF