Project

General

Profile

Bug #10646

Reinstall package process stalls at pfBlockerNG when restoring a config

Added by Steve Wheeler 5 months ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
Start date:
06/09/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:
All

Description

The package install process for pfBlockerNG completes but the processes do not close out preventing subsequent packages being installed:

root    90074   0.0  1.9 103252 38972 u0- I    17:11    0:00.37 |-- /usr/local/bin/php-cgi -f /etc/rc.package_reinstall_all
root    41960   0.0  0.3  10632  5192  -  I    17:12    0:00.00 | `-- /usr/local/sbin/pkg-static install -y -f pfSense-pkg-pfBlockerNG-devel
root    42288   0.0  0.9  24968 17220  -  I    17:12    0:00.53 |   `-- /usr/local/sbin/pkg-static install -y -f pfSense-pkg-pfBlockerNG-devel
root    18639   0.0  0.0      0     0  -  Z    17:13    0:00.02 |     |-- <defunct>
root    21643   0.0  0.1   4644  2092  -  S    17:13    0:00.00 |     |-- /usr/local/sbin/clog_pfb -f /var/log/filter.log
root    21653   0.0  1.9  51972 37560  -  S    17:13    0:00.93 |     |-- /usr/local/bin/php_pfb -f /usr/local/pkg/pfblockerng/pfblockerng.inc filterlog
root    52514   0.0  0.0      0     0  -  Z    17:12    0:32.12 |     |-- <defunct>
root    54546   0.0  0.0      0     0  -  Z    17:12    0:00.02 |     |-- <defunct>
root    58078   0.0  0.0      0     0  -  Z    17:12    0:00.00 |     |-- <defunct>
root    58300   0.0  0.0      0     0  -  Z    17:12    0:00.28 |     |-- <defunct>
root    58374   0.0  0.0      0     0  -  Z    17:12    0:00.03 |     |-- <defunct>
root    60793   0.0  0.0      0     0  -  Z    17:12    0:00.00 |     |-- <defunct>
root    61062   0.0  0.3  10500  6504  -  S    17:12    0:00.01 |     |-- /usr/local/sbin/lighttpd_pfb -f /var/unbound/pfb_dnsbl_lighty.conf
root    61126   0.0  1.8  51908 36260  -  I    17:12    0:00.12 |     | |-- /usr/local/bin/php -f /usr/local/pkg/pfblockerng/pfblockerng.inc dnsbl
root    61176   0.0  1.8  51908 36260  -  I    17:12    0:00.12 |     | `-- /usr/local/bin/php -f /usr/local/pkg/pfblockerng/pfblockerng.inc index
root    61396   0.0  1.9  51908 37896  -  S    17:12    0:00.30 |     `-- /usr/local/bin/php -f /usr/local/pkg/pfblockerng/pfblockerng.inc queries

Killing those processes manually allows the re-install package process to continue.

Likely the same cause as: https://redmine.pfsense.org/issues/10610

History

#1 Updated by Renato Botelho about 1 month ago

  • Status changed from New to Duplicate

Duplicate of #10610

Also available in: Atom PDF