Project

General

Profile

Bug #1075

rrd graphs missing / duplicate

Added by Martin Klein over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
RRD Graphs
Target version:
Start date:
12/06/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

On the rrd page the first graph
(11 hours / 1 min avg) is shown twice
instead of the daily graph.
See included screenshot.

screen.png (86 KB) screen.png Screenshot of rrd page. Martin Klein, 12/06/2010 04:40 AM
screen2.png (98.1 KB) screen2.png Screenshot of rrd page. Martin Klein, 12/27/2010 05:26 AM
duplicaterrdgone.jpg (563 KB) duplicaterrdgone.jpg JohnPoz _, 01/04/2011 02:49 PM
rrd.txt (1.06 KB) rrd.txt error log Martin Klein, 01/05/2011 11:22 AM
Unbenannt-1.jpg (153 KB) Unbenannt-1.jpg error screen Martin Klein, 01/05/2011 11:22 AM

History

#1 Updated by Chris Buechler over 8 years ago

  • Target version set to 2.0

#2 Updated by Ermal Lu├ži over 8 years ago

There were some commits related to RRD can you please try a new snapshot.

#3 Updated by Chris Buechler over 8 years ago

  • Status changed from New to Feedback

#4 Updated by Martin Klein over 8 years ago

Sorry for the delay.

The Problem is still there.
See attached screenshot of recent
snapshot.

#5 Updated by JohnPoz _ over 8 years ago

I no longer see this issue.

mysnap
2.0-BETA5 (i386)
built on Mon Jan 3 13:22:20 EST 2011

#6 Updated by Martin Klein over 8 years ago

Well the issue seems to change a bit depending
on the current time.

at 17:18 (gmt+1) i see :

1h , 1min avg
1d , 5min avg
3d , 5min avg
1w , 1h avg
2m , 1d avg
1w , 1h avg(the second time)
3y , 1d avg

at 00:26 (gmt+1) i see:

the first graph shows an error image ( see screenshot and attached log)
Jan 5 00:26:20 php: /status_rrd_graph_img.php: start 1294210800 is smaller than end 1294183579

something in the interval calculation seems
to be wrong.

#7 Updated by Erik Fonnesbeck over 8 years ago

Have you tried this on a newer snapshot? The Current Period graph at 12:00am to 7:59am should be working properly now. As for the first two graphs being the same during that time period, it is just because of how the graphing for the Current Period option is designed.

#8 Updated by Martin Klein over 8 years ago

The problem seems solved, i will continue
to test it at different times of day.
If i find further problems I will reopen
the ticket.

Thank You

#9 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF