Project

General

Profile

Actions

Bug #10900

closed

/packages/backup/backup.php?a=download&t=backup HTTP 504, or Sends PHP Error Message as ASCII/Text file Named pfsense.bak.tgz

Added by R M over 3 years ago. Updated 12 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Backup
Target version:
-
Start date:
09/13/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

ISSUE

Unable to download pfsense.bak.tgz backup file via web GUI.

STEPS TO REPRODUCE

  1. Go to /packages/backup/backup.php
  2. Click teal Backup button under Backup and Restore.
  3. Wait for 504 Gateway Time-out response from nginx, or bad pfsense.bak.tgz to download.

ERROR MESSAGE

Crash report begins.  Anonymous machine information:

amd64
11.3-STABLE
FreeBSD 11.3-STABLE #243 abf8cba50ce(RELENG_2_4_5): Tue Jun  2 17:53:37 EDT 2020     root@buildbot1-nyi.netgate.com:/build/ce-crossbuild-245/obj/amd64/YNx4Qq3j/build/ce-crossbuild-245/sources/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[xx-xxx-xxxx xx:27:21] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 793714688 bytes) in /usr/local/www/packages/backup/backup.php on line 80

No FreeBSD crash data found.

ATTACHED FILES

  • PHP_errors.log
  • pfsense.bak.tgz
  • 1.png - 7.png: screens involved in process and errors.

NOTES

  • pfsense.bak.tgz downloaded via the web GUI is not a .tgz file, but is an ASCII/text file containing the PHP error message.
  • /root/backup/pfsense.bak.tgz is successfully created, and can be scp'ed.
  • pfSense Version: 2.4.5-Release-p1
  • Hypervisor: Microsoft Hyper-V 5.0 (Server 2012 R2)
  • Resources allocated:

Files

References.7z (341 KB) References.7z Referenced files R M, 09/13/2020 04:10 PM
Actions #1

Updated by Viktor Gurov over 3 years ago

  • Project changed from pfSense to pfSense Packages
  • Category deleted (Backup / Restore)

package: Backup

Please provide more information:
- directory/file to backup
- size
- filesystem space utilization

Actions #2

Updated by R M over 3 years ago

- directory/file to backup: /
- size (of backup file): ~800MB
- filesystem space utilization: ~19% before backup, ~24% afterwards

Actions #3

Updated by Jim Pingle over 3 years ago

  • Category set to Backup
Actions #4

Updated by Viktor Gurov about 2 years ago

  • Status changed from New to Feedback
  • Affected Version deleted (All)

Should be fixed in #11098.

Please re-test.

Actions #5

Updated by Jordan G almost 2 years ago

This is very similar to https://redmine.pfsense.org/issues/11098 - testing covered using both "/root" and "/" as backup directories; /root can be chosen and will successfully create the compressed file in the backup sub-directory /root/backup

Actions #6

Updated by Danilo Zrenjanin 12 months ago

  • Status changed from Feedback to Not a Bug

The References.7z file initially included indicates that the issue was with allocated PHP memory.

[13-Sep-2020 xx:27:21] PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 793714688 bytes) in /usr/local/www/packages/backup/backup.php on line 80

That's expected if you pulled anything from the GUI that had more than 500 Mbytes.

It's highly recommended to use console or SSH for such operations.

Actions

Also available in: Atom PDF