Project

General

Profile

Actions

Bug #11017

closed

Incorrect synchronizetoip value causing XMLRPC errors

Added by Manuel Piovan 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
XMLRPC
Target version:
Start date:
10/30/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

install or updating stunnel 5.50_5
was working on the previus version

Crash report begins.  Anonymous machine information:

amd64
11.3-STABLE
FreeBSD 11.3-STABLE #243 abf8cba50ce(RELENG_2_4_5): Tue Jun  2 17:53:37 EDT 2020     root@buildbot1-nyi.netgate.com:/build/ce-crossbuild-245/obj/amd64/YNx4Qq3j/build/ce-crossbuild-245/sources/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[30-Oct-2020 12:01:32 Europe/Rome] PHP Fatal error:  Uncaught XML_RPC2_InvalidUriException: Client URI 'https://:@:8443/xmlrpc.php' is not valid in /usr/local/share/pear/XML/RPC2/Client.php:167
Stack trace:
#0 /usr/local/share/pear/XML/RPC2/Backend/Php/Client.php(80): XML_RPC2_Client->__construct('https://:@:8443...', Array)
#1 /usr/local/share/pear/XML/RPC2/Client.php(238): XML_RPC2_Backend_Php_Client->__construct('https://:@:8443...', Array)
#2 /etc/inc/xmlrpc_client.inc(92): XML_RPC2_Client::create('https://:@:8443...', Array)
#3 /etc/inc/xmlrpc_client.inc(153): pfsense_xmlrpc_client->xmlrpc_internal('merge_installed...', Array, 100)
#4 /usr/local/pkg/stunnel.inc(237): pfsense_xmlrpc_client->xmlrpc_method('merge_installed...', Array, 100)
#5 /usr/local/pkg/stunnel.inc(216): stunnel_do_xmlrpc_sync('', '8443', 'https', '', '', 100)
#6 /usr/local/pkg/stunnel.inc(110): stunnel_sync_config()
#7 /etc/inc/pkg-utils.inc(770) : eval()'d code(1): stunnel_save()
#8 /etc/inc/pkg-utils.inc(770): eval()
#9 /etc/inc/pkg-utils.inc(863): eval_once('stunnel_save();')
#10 /etc in /usr/local/share/pear/XML/RPC2/Client.php on line 167
[30-Oct-2020 12:01:34 Europe/Rome] PHP Fatal error:  Uncaught XML_RPC2_InvalidUriException: Client URI 'https://:@:8443/xmlrpc.php' is not valid in /usr/local/share/pear/XML/RPC2/Client.php:167
Stack trace:
#0 /usr/local/share/pear/XML/RPC2/Backend/Php/Client.php(80): XML_RPC2_Client->__construct('https://:@:8443...', Array)
#1 /usr/local/share/pear/XML/RPC2/Client.php(238): XML_RPC2_Backend_Php_Client->__construct('https://:@:8443...', Array)
#2 /etc/inc/xmlrpc_client.inc(92): XML_RPC2_Client::create('https://:@:8443...', Array)
#3 /etc/inc/xmlrpc_client.inc(153): pfsense_xmlrpc_client->xmlrpc_internal('merge_installed...', Array, 100)
#4 /usr/local/pkg/stunnel.inc(237): pfsense_xmlrpc_client->xmlrpc_method('merge_installed...', Array, 100)
#5 /usr/local/pkg/stunnel.inc(216): stunnel_do_xmlrpc_sync('', '8443', 'https', '', '', 100)
#6 /usr/local/pkg/stunnel.inc(110): stunnel_sync_config()
#7 /etc/inc/pkg-utils.inc(707) : eval()'d code(1): stunnel_save()
#8 /etc/inc/pkg-utils.inc(707): eval()
#9 /etc/rc.start_packages(63): sync_package('stunnel')
#10 {main}
  t in /usr/local/share/pear/XML/RPC2/Client.php on line 167
[30-Oct-2020 12:03:00 Europe/Rome] PHP Fatal error:  Uncaught XML_RPC2_InvalidUriException: Client URI 'https://:@:8443/xmlrpc.php' is not valid in /usr/local/share/pear/XML/RPC2/Client.php:167
Stack trace:
#0 /usr/local/share/pear/XML/RPC2/Backend/Php/Client.php(80): XML_RPC2_Client->__construct('https://:@:8443...', Array)
#1 /usr/local/share/pear/XML/RPC2/Client.php(238): XML_RPC2_Backend_Php_Client->__construct('https://:@:8443...', Array)
#2 /etc/inc/xmlrpc_client.inc(92): XML_RPC2_Client::create('https://:@:8443...', Array)
#3 /etc/inc/xmlrpc_client.inc(153): pfsense_xmlrpc_client->xmlrpc_internal('merge_installed...', Array, 100)
#4 /usr/local/pkg/stunnel.inc(237): pfsense_xmlrpc_client->xmlrpc_method('merge_installed...', Array, 100)
#5 /usr/local/pkg/stunnel.inc(216): stunnel_do_xmlrpc_sync('', '8443', 'https', '', '', 100)
#6 /usr/local/pkg/stunnel.inc(110): stunnel_sync_config()
#7 /etc/inc/pkg-utils.inc(770) : eval()'d code(1): stunnel_save()
#8 /etc/inc/pkg-utils.inc(770): eval()
#9 /etc/inc/pkg-utils.inc(863): eval_once('stunnel_save();')
#10 /etc in /usr/local/share/pear/XML/RPC2/Client.php on line 167

No FreeBSD crash data found.
Actions #2

Updated by Manuel Piovan 12 months ago

noticed now but can be the same reason as/a duplicate of
https://redmine.pfsense.org/issues/11014

Actions #3

Updated by Viktor Gurov 12 months ago

  • Project changed from pfSense Packages to pfSense
  • Subject changed from stunnel 5.50_5 Crash report begins on install to incorrect synchronizetoip value causes XMLRPC errors
  • Category changed from stunnel to High Availability

`synchronizetoip` input validation to avoid XMLRPC errors:
https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/34

Actions #4

Updated by Renato Botelho 12 months ago

  • Status changed from New to Feedback
  • Assignee set to Viktor Gurov
  • Target version set to 2.5.0

PR has been merged. Thanks!

Actions #6

Updated by Renato Botelho 12 months ago

PR has been merged. Thanks!

Actions #7

Updated by Danilo Zrenjanin 12 months ago

  • Status changed from Feedback to Resolved

Tested the patch on 2.4.5-p1. It works fine.

Actions #8

Updated by Jim Pingle 11 months ago

  • Subject changed from incorrect synchronizetoip value causes XMLRPC errors to Incorrect synchronizetoip value causing XMLRPC errors
  • Category changed from High Availability to XMLRPC
Actions

Also available in: Atom PDF