Project

General

Profile

Actions

Bug #1102

closed

Captive Portal does not work after upgrade

Added by Edan Pedragosa almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
Start date:
12/14/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

I upgraded to the latest snapshot 14 December but it failed the captive portal
access.

Whenever I activate captive portal, the user is not redirected anymore
to the portal page and so, no internet joy.

When I deactivate captive portal, internet connection is working fine.

I tried reinstalling from scratch using the same snapshot but no joy too.

Any help?

Actions #1

Updated by Chris Buechler almost 11 years ago

  • Category set to Operating System
  • Target version set to 2.0
  • Affected Version set to 2.0

I'm almost certain this is a duplicate of #1096, which describes the actual cause, but will leave it open to make sure that fixes it.

Actions #2

Updated by Life Form almost 11 years ago

Same here happened on snapshot 14December, 13 December, 8December.
So now I'm using December 1 snapshot.

Actions #3

Updated by gerard grazzini almost 11 years ago

Hello, the probleme is present for me too with build on : built on Tue Dec 14 05:32:26 EST 2010
and the probleme is not present befor to upgrad (with a snapshot from around the 3 or 4 decembre ?)
i don"t use any other package .... hope that can help

Actions #4

Updated by Jim Pingle almost 11 years ago

As a test, I have built a custom firmware image without the TSO patch that Chris mentioned. It would help us narrow down the problem if you could test with the appropriate firmware below to see if the portal works when using that image:

amd64 - http://pingle.org/files/pfSense-Full-Update-2.0-BETA4-20101212-2328.tgz

i386 - http://pingle.org/files/pfSense-Full-Update-2.0-BETA4-20101214-1319.tgz

If it works with that firmware image, then we will know it is related to the other open ticket (#1096).

Actions #5

Updated by Thomas NOEL almost 11 years ago

Olé,

Jim P wrote:

(...) It would help us narrow down the problem if you
could test with the appropriate firmware below to see if the portal
works when using that image (...)

Thanks a lot.

However, I tested this firmware : it does not solve the redirection issue (the redirection to the auth page).

--
Thomas

Actions #6

Updated by Thomas NOEL almost 11 years ago

Thomas NOEL wrote:

However, I tested this firmware (...)

Just for information : the captive portal works with pfSense-Full-Update-2.0-BETA4-20101201-2252.tgz

I will test the latest firmware (1202, 1203, etc) tomorrow (I'm in europe)...

Actions #7

Updated by Thomas NOEL almost 11 years ago

Thomas NOEL wrote:

the captive portal works with pfSense-Full-Update-2.0-BETA4-20101201-2252.tgz

works with pfSense-Full-Update-2.0-BETA4-20101207-0051.tgz too...

Actions #8

Updated by Thomas NOEL almost 11 years ago

Thomas NOEL wrote:

Thomas NOEL wrote:

the captive portal works with pfSense-Full-Update-2.0-BETA4-20101201-2252.tgz

works with pfSense-Full-Update-2.0-BETA4-20101207-0051.tgz too...

Ok, this is the result of my tests :
  • pfSense-Full-Update-2.0-BETA4-20101208-0906.tgz = redirect to :8000 works
  • pfSense-Full-Update-2.0-BETA4-20101208-2005.tgz = it does not

So, there is something new in "20101208-2005" which breaks packet forwarding...

Actions #9

Updated by Jim Pingle almost 11 years ago

What was new at that time is the patch that was backed out of the firmware updates I built above, and it will also be gone from the next new snapshot. I deactivated the patch in our repo and started the builders on a new run late this afternoon. It will probably be late tonight or early tomorrow AM before the new image sets are uploader, give it a try tomorrow and see if it works.

Actions #10

Updated by Thomas NOEL almost 11 years ago

Tested pfSense-Full-Update-2.0-BETA4-20101216-0237.tgz : no redirection... :(

Does this update include the (anti-)patch ?

Actions #11

Updated by Jim Pingle almost 11 years ago

Yes, that update should no longer contain the patch in question. So it may not be related to that one after all.

Actions #12

Updated by Thomas NOEL almost 11 years ago

Hello,

Found a solution : # /sbin/sysctl net.inet.ip.fastforwarding=1

I think the regression came from 4f76b144

Thanks

Actions #13

Updated by gerard grazzini almost 11 years ago

with 2.0-BETA4 (i386) built on Fri Dec 17 01:17:30 EST 2010
the Captive Portal still be broken for me ...

Actions #14

Updated by Thomas NOEL almost 11 years ago

gerard grazzini wrote:

with 2.0-BETA4 (i386) built on Fri Dec 17 01:17:30 EST 2010
the Captive Portal still be broken for me ...

Can you try this (on a shell) : # /sbin/sysctl net.inet.ip.fastforwarding=1

It works for me.

Actions #15

Updated by Karsten H. almost 11 years ago

Same problem here! As soon as I enable captive portal there is no redirect and no more internet access on that interface.

Using 2.0-BETA4 (i386)built on Thu Dec 16 14:34:04 EST 2010
same with 2.0-BETA4 (i386) built on Fri Dec 17 01:17:30 EST 2010

Haven't tried the shell command yet. Will try this later that day.

Actions #16

Updated by Karsten H. almost 11 years ago

Thomas NOEL wrote:

Can you try this (on a shell) :
  1. /sbin/sysctl net.inet.ip.fastforwarding=1

It works for me.

Hello Thomas,
thank you very much! The captive portal is working now.

What does that switch do? - Why does the captive portal work with that option enabled?

Actions #17

Updated by Ermal Luçi almost 11 years ago

  • Status changed from New to Feedback

Please test new snapshots it should be fixed.

Actions #18

Updated by Nick K almost 11 years ago

Thomas NOEL wrote:

Hello,

Found a solution : # /sbin/sysctl net.inet.ip.fastforwarding=1

I think the regression came from 4f76b144

Thanks

This is working for me also
Thanks Thomas for finding this

Actions #19

Updated by Thomas NOEL almost 11 years ago

Ermal Luçi wrote:

Please test new snapshots it should be fixed.

I've just tested 2.0-BETA4 (i386) built on Fri Dec 17 14:14:00 EST 2010
(pfSense-Full-Update-2.0-BETA4-20101217-1036.tgz) : it does not solve the bug...

Thanks

Actions #20

Updated by Chris Buechler almost 11 years ago

That date is an hour before the fix was committed and comment here. "test new snapshots" always means a date of at least a few hours after, if not the next day.

Actions #21

Updated by Alfredo Frugone almost 11 years ago

I just upgrade to 2.0-BETA4 (i386) built on Sat Dec 18 09:51:58 EST 2010, and still the same problem.

Thanks

Actions #22

Updated by Thomas NOEL almost 11 years ago

Hello,

I've tested today with pfSense-Full-Update-2.0-BETA4-20101219-0151.tgz (built on Sun Dec 19 05:36:18 EST) : bad news, the redirection to the captive portal does not work.

A difference : the hack "net.inet.ip.fastforwarding=1" does not work too.

Thanks

Actions #23

Updated by Ermal Luçi almost 11 years ago

I fixed it right now.
https://rcs.pfsense.org/projects/pfsense/repos/mainline/commits/4cc233748fa7e79ac743364404152b7685c81288

Beaware that fastforwarding and CP will never work together on pfSense from now on.

Actions #24

Updated by Thomas NOEL almost 11 years ago

Ermal Luçi wrote:

I fixed it right now.
https://rcs.pfsense.org/projects/pfsense/repos/mainline/commits/4cc233748fa7e79ac743364404152b7685c81288
Beaware that fastforwarding and CP will never work together on pfSense from now on.

Yes, it works !! Thanks a lot !

Actions #25

Updated by Chris Buechler almost 11 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF