Project

General

Profile

Bug #11050

"Backup extra data" does not behave properly

Added by Jim Pingle 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Backup / Restore
Target version:
Start date:
11/09/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:
Release Notes:
Default

Description

When backup up with "Backup Extra Data" checked, there are a few problems:

  • Tags are not removed during every restore path (e.g. PFI during installer as with #7634 for RRD, ECL, or restore_backup() in general), so they may remain in config.xml indefinitely
  • Duplicate tags are not removed on restore as is done for rrddata
  • Error when restoring a config generated after backup, restore, then backup again due to the duplicated tags (Like #8994 for RRD)
  • Backup Extra Data defaults to on, should be off.

See also: #10910, #10868, #10856, #8994, #7634

Associated revisions

Revision b3cc5117 (diff)
Added by Viktor Gurov 5 months ago

Backup extra data fixes. Issue #11050

History

#2 Updated by Renato Botelho 5 months ago

  • Status changed from Confirmed to Pull Request Review
  • Assignee set to Viktor Gurov

#3 Updated by Jim Pingle 5 months ago

The PR Addresses the last three points but not the first.

Part of the first one will need fixed in the src repo in the installer, like https://gitlab.netgate.com/pfSense/FreeBSD-src/-/commit/b76e6a64c0b948808a0260f4ce702f2e8866de86

The ECL method (https://gitlab.netgate.com/pfSense/pfSense/-/blob/master/src/etc/ecl.php) will need to be changed as well so it's similar to restoring from the GUI

#6 Updated by Renato Botelho 5 months ago

  • Status changed from Pull Request Review to Feedback

PR has been merged. Thanks!

#7 Updated by Max Leighton 3 months ago

  • Status changed from Feedback to Resolved

Tested in a recent build and am seeing that the extra data is being cleared. No duplicate tags are present on second restore since the tags are cleared after the initial restore.

Also available in: Atom PDF