Project

General

Profile

Bug #11254

Some OpenVPN configuration files remain after deleting an instance

Added by Viktor Gurov about 2 months ago. Updated 25 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
01/16/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:

Description

If you delete OpenVPN Server/Client in the WebGUI, no all config files/directories will be deleted:

/var/etc/openvpn/client3/
/var/etc/openvpn/client3/ca
/var/etc/openvpn/client3/ca/791c09ae.0
/var/etc/openvpn/client3/csc
/var/etc/openvpn/server3/
/var/etc/openvpn/server3/ca
/var/etc/openvpn/server3/ca/791c09ae.0
/var/etc/openvpn/server3/csc

Associated revisions

Revision 79ec3f15 (diff)
Added by Viktor Gurov about 1 month ago

Delete all OpenVPN related files on instance deletion. Issue #11254

Revision 93830bec (diff)
Added by Viktor Gurov 29 days ago

OpenVPN rmdir fix. Issue #11254

History

#1 Updated by Viktor Gurov about 2 months ago

  • Subject changed from not all config files on instance deletion to not all config files are deleted on instance deletion

#3 Updated by Jim Pingle about 2 months ago

  • Subject changed from not all config files are deleted on instance deletion to Some OpenVPN configuration files remain after deleting an instance
  • Status changed from New to Pull Request Review
  • Target version set to 2.5.0

#4 Updated by Renato Botelho about 1 month ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

#5 Updated by Danilo Zrenjanin about 1 month ago

  • Status changed from Feedback to Resolved

Tested on the latest release. It works as expected. Ticket resolved.

#6 Updated by Viktor Gurov 29 days ago

  • Status changed from Resolved to New
  • Priority changed from Low to Normal

sometime for some reason it shows PHP error:

[04-Feb-2021 13:01:43 Europe/Moscow] PHP Warning:  rmdir(/var/etc/openvpn/server1): Directory not empty in /etc/inc/pfsense-utils.inc on line 1017

fix:
https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/122

#7 Updated by Renato Botelho 29 days ago

  • Status changed from New to Pull Request Review

#8 Updated by Renato Botelho 29 days ago

  • Status changed from Pull Request Review to Feedback

Merged

#9 Updated by Max Leighton 25 days ago

In the February 4 image of 2.5, I can no longer get the PHP crash after deleting the server/client instance of OpenVPN.

I still have directories the following directories in /var/etc/openvpn:

/var/etc/openvpn/server1
/var/etc/openvpn/server1/csc
/var/etc/openvpn/client2
/var/etc/openvpn/client2/csc

These are empty directories which will stay until the firewall is rebooted. Following a reboot, /var/etc/openvpn is completely empty.

If that is the expected behavior, then this can be resolved. I have not been able to reproduce the PHP crash since upgrading to the February 4 image.

#10 Updated by Viktor Gurov 25 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF