Project

General

Profile

Actions

Bug #11969

closed

PHP error if no DHCPv6 Relay interfaces are selected

Added by Viktor Gurov 6 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP Relay
Target version:
Start date:
05/27/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Default
Affected Version:
2.6.0
Affected Architecture:

Description

How to reproduce:
Unselect all interfaces on the services_dhcpv6_relay.php and uncheck "Enable"
Result:

Crash report details:

PHP Errors:
[27-May-2021 18:11:36 Europe/Moscow] PHP Warning:  implode(): 
Invalid arguments passed in /usr/local/www/services_dhcpv6_relay.php on line 130

It should check `interface` array, see https://github.com/pfsense/pfsense/blob/cf8a0761c5c2ae80b62743d6d476e0fae6f2495e/src/usr/local/www/services_dhcp_relay.php#L115:

        if (isset($_POST['interface']) &&
            is_array($_POST['interface'])) {
            $config['dhcrelay']['interface'] = implode(",",
                $_POST['interface']);
        }


Related issues

Has duplicate Bug #12014: Invalid arguments passed in services_dhcpv6_relay.php on line 116Duplicate06/08/2021

Actions
Actions #2

Updated by Jim Pingle 6 months ago

  • Subject changed from PHP error if none DHCPv6 Relay interfaces selected to PHP error if no DHCPv6 Relay interfaces are selected
  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
  • Target version set to 2.6.0
  • Plus Target Version set to 21.09
Actions #3

Updated by Jim Pingle 6 months ago

  • Has duplicate Bug #12014: Invalid arguments passed in services_dhcpv6_relay.php on line 116 added
Actions #4

Updated by Renato Botelho 5 months ago

  • Status changed from Pull Request Review to Feedback

PR has been merged. Thanks!

Actions #5

Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved

Unable to reproduce the errors on a current snapshot. Looks good to me.

Actions #6

Updated by Jim Pingle about 1 month ago

  • Plus Target Version changed from 21.09 to 22.01
Actions

Also available in: Atom PDF