Project

General

Profile

Actions

Bug #12030

open

Startup Errors for Avahi Package

Added by Kris Phillips about 2 months ago. Updated 4 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Avahi
Target version:
-
Start date:
06/12/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.5.x
Affected Plus Version:
Affected Architecture:

Description

The avahi package is complaining about NSS support being missing and dependency errors on startup in 2.5.2.

WARNING: No NSS support for mDNS detected, consider installing nss-mdns!

Additionally, there is errors about service groups:

Failed to add service 'pfSense' of type '_ssh._tcp', ignoring service group (/usr/local/etc/avahi/services/ssh.service): Not permitted

Actions #1

Updated by Jim Pingle about 2 months ago

  • Project changed from pfSense to pfSense Packages
  • Category changed from Unknown to Avahi
  • Release Notes deleted (Default)
Actions #2

Updated by Kris Phillips about 2 months ago

This issue is still present in the June 17th build.

Actions #3

Updated by Steve Wheeler about 2 months ago

The service warnings are expected if you don't have publishing enabled. It's disabled by default.
See: https://forum.netgate.com/post/802623

Actions #4

Updated by Kris Phillips about 1 month ago

Confirmed this is the case. We may want to consider making this a "more friendly" error, as it looks like a bug until you know this.

However, the NSS support message is still there even with publishing enabled.

WARNING: No NSS support for mDNS detected, consider installing nss-mdns!

Actions #5

Updated by Kris Phillips 4 days ago

Tested in 21.05.1 and this is still a present error:

WARNING: No NSS support for mDNS detected, consider installing nss-mdns!

Actions

Also available in: Atom PDF