Project

General

Profile

Actions

Regression #12245

closed

Input validation error in system.php

Added by Steve Wheeler 4 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Force Exclusion
Affected Version:
2.6.0
Affected Architecture:
All

Description

The input validation in system.php incorrectly prevents numeric hostnames in 2.6 and 21.09. For example '3100' or '2600'.

This is a regression since 2.5.2 / 21.05

Tested:

21.09-DEVELOPMENT (amd64)
built on Wed Aug 11 01:17:52 EDT 2021
FreeBSD 12.2-STABLE

2.6.0-DEVELOPMENT (amd64)
built on Wed Aug 11 01:15:06 EDT 2021
FreeBSD 12.2-STABLE


Files


Related issues

Related to Bug #12000: Remote log server input validation allows invalid valuesResolvedViktor Gurov06/06/2021

Actions
Actions

Also available in: Atom PDF