Project

General

Profile

Actions

Regression #12340

closed

Factory Reset Menu Broken in webConfigurator

Added by Kris Phillips about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Web Interface
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:
All

Description

In the latest Sept 4th build of pfSense Plus 21.09 the Factory Reset menu under Diagnostics --> Factory Reset does not function and throws an error. Resetting from the serial console works fine.

Error Message:
Fatal error: Uncaught Error: Call to undefined function get_pkg_info() in /etc/inc/config.lib.inc:725
Stack trace:
#0 /usr/local/www/diag_defaults.php(51): reset_factory_defaults()
#1 {main}
thrown in /etc/inc/config.lib.inc on line 725
PHP ERROR: Type: 1, File: /etc/inc/config.lib.inc, Line: 725, Message: Uncaught Error: Call to undefined function get_pkg_info() in /etc/inc/config.lib.inc:725
Stack trace:
#0 /usr/local/www/diag_defaults.php(51): reset_factory_defaults()
#1 {main}
thrown

Actions #1

Updated by Kris Phillips about 1 month ago

On further testing it appears it does still complete the factory reset, but it takes significantly longer as it seems to hang on something.

Actions #2

Updated by Kris Phillips about 1 month ago

Additionally testing: After the "factory reset" the wizard did not launch. Some components were reset, but not all.

Actions #3

Updated by Steve Wheeler about 1 month ago

  • Priority changed from Normal to Urgent

Confirmed in 21.09. Tested:

21.09-BETA (amd64)
built on Sun Sep 05 01:12:47 EDT 2021
FreeBSD 12.2-STABLE

2.6 is not affected.

Actions #4

Updated by Steve Wheeler about 1 month ago

  • Private changed from No to Yes

This same issue was fixed in the console by: https://gitlab.netgate.com/pfSense/factory/-/commit/f8b02f65792ae1e666b124bc53474fc2c943e4a4

The same fix applied to diag_defaults.php fixes this issue.

Actions #5

Updated by Steve Wheeler about 1 month ago

  • Target version set to 21.09
  • Private changed from Yes to No
Actions #7

Updated by Luiz Souza about 1 month ago

  • Status changed from New to Feedback

2.6 was also affected, but I fixed quickly after I found the problem.

Both cases are fixed.

Actions #8

Updated by Luiz Souza about 1 month ago

  • % Done changed from 0 to 100
  • Affected Architecture All added
  • Affected Architecture deleted (amd64)
Actions #9

Updated by Jim Pingle about 1 month ago

  • Tracker changed from Bug to Regression
  • Project changed from pfSense Plus to pfSense
  • Category changed from Web Interface to Web Interface
  • Assignee set to Luiz Souza
  • Target version changed from 21.09 to 2.6.0
  • Release Notes changed from Default to Force Exclusion
  • Affected Plus Version deleted (21.09)
  • Plus Target Version set to 21.09

Moving to main project since it did end up affecting both CE and Plus.

Excluding from release notes since it was not a problem in a release.

Actions #10

Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Works fine now.

Actions #11

Updated by Luiz Souza about 1 month ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF