Project

General

Profile

Actions

Bug #12341

closed

Gateway Monitoring Percentage Not Decreasing After Gateway Packet Loss Event

Added by Kris Phillips about 1 month ago. Updated 17 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
21.09
Affected Architecture:
amd64

Description

Under Status --> Gateways if a gateway in 21.09 BETA (Sept 4th build) experiences packet loss the packet loss percentage counter will not reset until navigating away from and back to the Gateway Status page. Refreshing the page keeps the same percentage forever no matter how many times you refresh. Additionally any status messages will remain as well (such as Packet Loss Warnings or Down messages). Tested on Firefox 91.0.2.

See attached screenshots and here is a ping test from WAN when the interface was "Down" according to the status page even though the system logs showed the gateway event as being cleared:

PING 8.8.8.8 (8.8.8.8) from 172.21.92.102: 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=107 time=53.539 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=107 time=66.009 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=107 time=57.102 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=107 time=45.526 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=107 time=46.110 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=107 time=46.926 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=107 time=52.594 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=107 time=43.971 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=107 time=54.772 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=107 time=51.236 ms

--- 8.8.8.8 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 43.971/51.778/66.009/6.321 ms


Files

PacketLoss.png (51.2 KB) PacketLoss.png Status Page After Repeated Refreshes Kris Phillips, 09/04/2021 09:26 PM
AfterLeaveAndReturn.png (49.2 KB) AfterLeaveAndReturn.png After Navigating Away and Back Kris Phillips, 09/04/2021 09:27 PM
Actions #1

Updated by Jim Pingle about 1 month ago

  • Status changed from New to Feedback

There isn't anything on the page which could do that, it must be your browser cache. Try shift+reload or ctrl+F5 and see if it makes a difference.

Clicking the page title or clicking refresh should have the same effect as navigating away and coming back. If they don't, then your browser or an extension is doing something it shouldn't be. Chrome in particular is known for overly aggressive caching like this.

Actions #2

Updated by Kris Phillips about 1 month ago

This was tested in Firefox 91, per the original post. It's possible it's caching, but it's odd the rest of the fields get updated but not the packet loss counter. The packet loss percentage is the ONLY field that doesn't update.

I retested with a fresh browser and no extensions or add-ons. Clicking on the "Gateways" button on the top refreshes the RTT and RTTsd fields just fine. It's just the packet loss percentage that doesn't. After refreshing for a solid 45-50 seconds, however, it will very suddenly jump from whatever packet loss it had to 0%. There is definitely something different about the way that field is updated versus the others.

Actions #3

Updated by Jordan Greene about 1 month ago

tested on XG-7100 running 21.09.b.20210911.0100

ensured gateway monitoring was enabled, then created icmp block on primary firewall for the 7100. Packet loss incrementally climbed to 100% while monitoring the dashboard on the 7100, upon removal of the rule the packet loss percentage made it's way back to zero. Firefox 92 on Ubuntu 18.04

Actions #4

Updated by Kris Phillips 29 days ago

Odd. Not sure why I'm the only one that can't reproduce this one, but this can be closed out. Clearly my testing is an outlier here.

Actions #5

Updated by Danilo Zrenjanin 17 days ago

  • Status changed from Feedback to Resolved

I tested on XG-7100 latest RC.

I can confirm it works as expected. I am resolving this ticket.

Actions

Also available in: Atom PDF