Project

General

Profile

Bug #1243

GUI/Backend code needs updated after multi-PPPoE-server code switch

Added by Vinícius Coque over 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
PPPoE Server
Target version:
Start date:
01/31/2011
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:
All

Description

After creating a PPPoE server a new tab should be displayed at Firewall Rules, but it isn't. Then I can't create rules to allow traffic for PPPoE connections.

pppoe.patch (5.54 KB) pppoe.patch Vinícius Coque, 02/01/2011 12:07 PM

Associated revisions

Revision 20fef17c (diff)
Added by Jim Pingle over 8 years ago

Show PPPoE tab if any of the PPPoE server instances are enabled. Fixes #1243

Revision 93c2c1e6 (diff)
Added by Jim Pingle over 8 years ago

Generalize pppoe server enabled check and use it elsewhere in the GUI that needed fixed. Still needs changes in filter.inc - Ticket #1243

Revision 8c5df705 (diff)
Added by Jim Pingle over 8 years ago

Also fix easyrule and auto->manual nat switch code. Ticket #1243

Revision ee6d2b52 (diff)
Added by Ermal Luçi about 8 years ago

Resolves #1243. Properly handle pppoe new format of config so correct rulesets are generated.

History

#1 Updated by Jim Pingle over 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Vinícius Coque over 8 years ago

Jim P your fix makes the PPPoE tab appear, but the firewall rules are not generated after applying changes. I attached a patch that fix it, can you take a look?

#3 Updated by Jim Pingle over 8 years ago

  • Status changed from Feedback to New

I fixed the places in the GUI that you saw (in a more general way) but the filter.inc changes need more care. What you have there isn't quite right, but I'd need more time with the code to figure out how to do it correctly.

#4 Updated by Jim Pingle over 8 years ago

  • Subject changed from PPPoE tab isn't displayed on firewall rules after creating a PPPoE server to GUI/Backend code needs updated after multi-PPPoE-server code switch

Ermal said he'd have a look at the filter.inc part when he gets a chance. Every other reference to the old style config for a single PPPoE server should be fixed. Once the filter.inc bit is done it should be fine.

#5 Updated by Deon George about 8 years ago

FWIW, the /etc/inc/filter.inc portion of Vinícius Coque's patch fixes my problem of PPPOE rules not being created for the PPPOE Server.

#6 Updated by Jim Pingle about 8 years ago

  • Category set to PPPoE Server
  • Target version set to 2.0
  • % Done changed from 100 to 60
  • Affected Architecture set to All

#7 Updated by Ermal Luçi about 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 60 to 100

#8 Updated by Chris Buechler almost 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF