Project

General

Profile

Actions

Regression #12559

closed

Firewall rule direction indicator is displayed on all interfaces

Added by Steve Wheeler 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Force Exclusion
Affected Version:
2.6.0
Affected Architecture:
All

Description

Following the changes applied for this feature: https://redmine.pfsense.org/issues/12433

Rules with a direction applied are now shown with an arrow in the firewall rules table.

However that is shown on rules on all interfaces but the config line only does anything to floating rules. Although it's only possible to add a direction to floating rules via the the normal webgui process any existing rules with one set on another interface becomes confusing. For example rules created by the OpenVPN wizard.

The direction indicator should only be displayed on the Floating Rules tab.


Files

Actions #2

Updated by Jim Pingle 6 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
Actions #3

Updated by Viktor Gurov 6 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle 6 months ago

  • Release Notes changed from Default to Force Exclusion

Bug in a newly added feature since the last release, so it doesn't need a release notes entry.

Actions #5

Updated by Max Leighton 6 months ago

  • Status changed from Feedback to Resolved

Tested on

2.6.0-DEVELOPMENT (amd64)
built on Sat Dec 04 06:23:51 UTC 2021
FreeBSD 12.3-PRERELEASE

The arrows are only present on floating rules now. Marking the ticket resolved.

Actions

Also available in: Atom PDF