Project

General

Profile

Actions

Bug #12712

closed

Errors bring down the system

Added by yon Liu 4 months ago. Updated 4 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Unknown
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description


Files

cn1.txt (12.7 KB) cn1.txt Aliases add to static routes yon Liu, 01/21/2022 05:36 AM
cn2.txt (6.98 KB) cn2.txt Aliases add to static routes yon Liu, 01/21/2022 05:36 AM
cn.txt (16.3 KB) cn.txt yon Liu, 01/21/2022 08:44 PM
Actions #1

Updated by yon Liu 4 months ago

One of the reasons for the problem is that if many static routes are added to the settings, the pf2.6 system will crash.
For example, adding the ip list in the attachment to the system route will cause problems.

Actions #2

Updated by Jim Pingle 4 months ago

  • Status changed from New to Not a Bug
  • Priority changed from Very High to Normal
  • Target version deleted (2.6.0)

I can't replicate this at all, but your two files have numerous overlapping networks which is invalid. Input validation now rejects it but it may not have in the past.

129.226.0.0/16
140.143.0.0/16
140.179.0.0/16
140.205.0.0/16
140.206.0.0/15
140.210.0.0/16
140.224.0.0/16
140.237.0.0/16
140.240.0.0/16
140.242.223.0/24
140.242.224.0/24
140.243.0.0/16
140.246.0.0/16
140.249.0.0/16
140.250.0.0/16
140.255.0.0/16
140.75.0.0/16
203.55.2.0/23
203.55.4.0/24
210.32.0.0/12
210.51.0.0/16
210.52.0.0/15
210.82.0.0/15
211.136.0.0/13
216.228.126.0/24

Those networks are in both cn1.txt and cn2.txt, you can't have two routes to the same destination.

Actions #3

Updated by yon Liu 4 months ago

This is the result of ip aggregation. Duplicates should be removed.
Attachment file updated.

Actions #4

Updated by Steve Wheeler 4 months ago

I can't replicate this either. Adding the static route works as expected. The routing table is updated.

Tested:

22.01-RC (amd64)
built on Sun Jan 23 01:50:24 UTC 2022
FreeBSD 12.3-STABLE

Actions #5

Updated by yon Liu 4 months ago

Supplementary note: The system environment has frr ipv6 bgp full route running.

pfsense 2.6 rc

Actions

Also available in: Atom PDF