Project

General

Profile

Actions

Todo #13236

closed

Document link speed limitations with igc and ix on 6100/4100

Added by Marcos M 3 months ago. Updated 26 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Products
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:

Description

The I225 built-in phy doesn't support fixed operation, so a speed/duplex setting is emulated by selecting that single value in the autonegotiation menu (this is what the Linux driver does).

NG 6069#note-5

This effectively means the igc ports will not work with explicitly set speeds at the other end. The behavior is observed with ix ports on the 6100 as well.

Actions #1

Updated by Marcos M 3 months ago

  • Subject changed from Document link speed limitations with igc and ix to Document link speed limitations with igc and ix on 6100/4100
Actions #2

Updated by Jim Pingle 2 months ago

Has that been tested and confirmed? I remember some discussion around that back when the driver was first brought in, but I don't recall if anyone confirmed it to be the case and I'm not turning up anything specific when searching on slack.

Actions #3

Updated by Marcos M 2 months ago

It's been tested by a customer, along with SW and CL.

At best, the ix and igc ports on both the 6100 and 4100 will fail back to autoselect if they are hard-set, linking at whichever speed is auto-negotiated. If the other side is hard-set, the ports will fail in different ways, but the result is the same - traffic will not flow.

Actions #4

Updated by Chris Linstruth 2 months ago

Which makes this language on the pfSense interface config pages, though correct, probably in need of some adjustment for these devices:

Explicitly set speed and duplex mode for this interface.
WARNING: MUST be set to autoselect (automatically negotiate speed) unless the port this interface connects to has its speed and duplex forced.
Actions #5

Updated by Jim Pingle 30 days ago

  • Assignee set to Jim Pingle
Actions #6

Updated by Jim Pingle 30 days ago

  • Status changed from New to In Progress
Actions #8

Updated by Marcos M 29 days ago

Note looks good, however when we tested this, the issue happened on the ix ports as well (see #note-3).

Actions #9

Updated by Jim Pingle 27 days ago

Marcos M wrote in #note-8:

Note looks good, however when we tested this, the issue happened on the ix ports as well (see #note-3).

All ix or just ix on 4100/6100? If only on 4100/6100, is it just the copper/RJ45 combo ports, or all ix ports on the 6100? Since the SFP would be locked to the speed of the module it's not clear how it might behave if the fiber module supports multiple speeds on the 10G SFP ports of the 6100. I'm curious if anyone has testing the behavior on SFP with a 1G/10G module on both ends and trying to force it to 1G. The GUI does offer a choice of limiting the media speed like it does for traditional ports.

Actions #10

Updated by Marcos M 27 days ago

For ix, it's the same on the 4100/5100/6100. I only see testing history on the RJ-45 ix ports, not SFP.

Actions #12

Updated by Jim Pingle 26 days ago

This should be better now:

https://gitlab.netgate.com/docs/pfsense-platforms/-/commit/ce3288bce4b70211f1296deddaa2c51a76c3927b

While there I also added notes about copper SFPs:

https://gitlab.netgate.com/docs/pfsense-platforms/-/commit/2e583df39e401b2821d109b5359c47deee46c248

(Which replaced some items in an alternate branch I cleaned up).

Actions #13

Updated by Marcos M 26 days ago

  • Status changed from Feedback to Resolved

Looks good, thanks!

Actions

Also available in: Atom PDF