Project

General

Profile

Actions

Bug #13280

closed

Entries for ``net.link.ifqmaxlen`` duplicated in ``/boot/loader.conf``

Added by Keith Townsend almost 2 years ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Operating System
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

Using 22.05-RC 22.05.r.20220617.0613 Duplicate entries appear in /boot/loader.conf
Here are the contents of my loader.conf file which I believe are default setttings.

kern.cam.boot_delay=10000
kern.ipc.nmbclusters="1000000" 
kern.ipc.nmbjumbop="524288" 
kern.ipc.nmbjumbo9="524288" 
opensolaris_load="YES" 
zfs_load="YES" 
kern.geom.label.gptid.enable="0" 
kern.geom.label.disk_ident.enable="0" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
autoboot_delay="3" 
hw.hn.vf_transparent="0" 
hw.hn.use_if_start="1" 
net.link.ifqmaxlen="128" 

Duplicate entry net.link.ifqmaxlen="128" appears to be added to loader.conf everytime the system is booted.

Actions #1

Updated by Marcos M almost 2 years ago

I'm seeing this as well on a VM with 22.05.r.20220609.1919.

kern.cam.boot_delay=10000
kern.ipc.nmbclusters="1000000" 
kern.ipc.nmbjumbop="524288" 
kern.ipc.nmbjumbo9="524288" 
opensolaris_load="YES" 
zfs_load="YES" 
kern.geom.label.gptid.enable="0" 
kern.geom.label.disk_ident.enable="0" 
kern.geom.label.disk_ident.enable="0" 
kern.geom.label.gptid.enable="0" 
opensolaris_load="YES" 
zfs_load="YES" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
net.link.ifqmaxlen="128" 
autoboot_delay="3" 
hw.hn.vf_transparent="0" 
hw.hn.use_if_start="1" 
net.link.ifqmaxlen="128" 

Actions #2

Updated by Joe Mott almost 2 years ago

I know this is probably a low priority bug since pfSense does not need to be rebooted frequently, but shouldn't this issue be assigned to a target version?

PHP is not my specialty, but the code does not appear to check for net.link.ifqmaxlen in loader.conf before adding it.

Actions #3

Updated by Jim Pingle almost 2 years ago

  • Subject changed from Entries duplicated in /boot/loader.conf to Entries for ``net.link.ifqmaxlen`` duplicated in ``/boot/loader.conf``
  • Category changed from Unknown to Operating System
  • Status changed from New to Confirmed
  • Priority changed from Normal to High
  • Target version set to 2.7.0
  • Plus Target Version set to 22.11

Yes, it should have a target. It definitely needs addressed and should be possible to patch between releases if needed.

Actions #4

Updated by Jim Pingle over 1 year ago

  • Plus Target Version changed from 22.11 to 23.01
Actions #5

Updated by Kristof Provost over 1 year ago

I cannot reproduce this on either CE (20221111) or Plus (of a similar vintage). Does this problem still occur on recent snapshots? If so, can you share a configuration file so I can attempt to reproduce again?

Actions #6

Updated by Jim Pingle over 1 year ago

  • Status changed from Confirmed to Feedback

I cannot reproduce this on current snapshots either. The only place I can reproduce it is on a 22.05 system.

I have multiple systems with one copy of that value in loader.conf, but none on snapshots with multiple.

If anyone can still reproduce this on a current dev snapshot, we'll need more information to go on.

Actions #7

Updated by Georgiy Tyutyunnik over 1 year ago

Version 2.7.0-DEVELOPMENT (amd64)
built on Fri Dec 02 06:04:46 UTC 2022
FreeBSD 14.0-CURRENT
Hyper-V VMs
net.link.ifqmaxlen="128" parameter is not duplicating, but I see the following duplicated strings:
kern.geom.label.gptid.enable="0"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
They do not multiplicate through the reboot. Is it relevant to the current issue?

Actions #8

Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

No, those are unrelated. They are added during the process that builds the images and are left as-is in the file, they aren't manipulated by the pfSense code.

Marking this resolved. If anyone can still reproduce it, we can always open it back up.

Actions #9

Updated by Jim Pingle 10 months ago

  • Affected Version set to 2.7.0
Actions

Also available in: Atom PDF