Project

General

Profile

Actions

Bug #13413

closed

Some messages presented to users contain relative links to pages which may be invalid when triggered from certain packages

Added by Lev Prokofev over 1 year ago. Updated 28 days ago.

Status:
Resolved
Priority:
Low
Category:
Web Interface
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
24.03
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

If something goes wrong when you save the config changes of Wireguard (can't determine what it was in my case)
you will get the message:
"There was a problem applying the changes. See the System Logs"

The "System logs" link goes to the 404 page and usr/local/www/wg/status_logs.php is not exist.


Files

clipboard-202208131325-tdxe9.png (30.4 KB) clipboard-202208131325-tdxe9.png Lev Prokofev, 08/13/2022 05:25 AM
Actions #1

Updated by Kris Phillips over 1 year ago

I can't reproduce this, but only because I can't get this error to pop up. I've tried intentionally breaking Wireguard to get it to do this and I'm not sure how to recreate it.

However, the URL for wireguard's configuration uses https://[IP of firewall]/wg/[insert php file here]. As such, any links to logging that use the global functions would try to tack in the /wg/ part, which is probably the core of the issue here. Probably need to update the PHP code here to not use the global functions and instead use something else.

Actions #2

Updated by aleksei prokofiev 5 months ago

Tested on
23.09-RELEASE (amd64)
built on Fri Nov 17 13:32:00 UTC 2023
FreeBSD 14.0-CURRENT

I've tried different setting to try get this error, but can't reproduce.

Actions #3

Updated by Christopher Cope 4 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Christopher Cope

https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/1111

I wasn't able to reproduce the error with Wireguard, but the functions for the error message use relative links, so I made a merge request to point them at the root domain.

Actions #4

Updated by Jim Pingle 4 months ago

  • Project changed from pfSense Packages to pfSense
  • Subject changed from link to not existed /wg/status_logs.php to Some messages presented to users contain relative links to pages which may be invalid when triggered from certain packages
  • Category changed from WireGuard to Web Interface
  • Target version set to 2.8.0
  • Plus Target Version set to 24.03
  • Release Notes set to Default

Moving projects/rewording since this isn't specific to any one package, it just happens to affect packages which put files in subdirectories.

Actions #5

Updated by Christopher Cope 3 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Jim Pingle 28 days ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF