Project

General

Profile

Actions

Bug #13513

closed

pfSense - Feature #13446: Upgrade PHP from 7.4 to 8.1

Cannot install Squid

Added by Peter Moreno 2 months ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Category:
Squid
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Affected Version:
2.7.x
Affected Plus Version:
Affected Architecture:
amd64

Description

I start testing the new version 2.7-devel with the new kernel 14 from freebsd.
I try to install squid, but I got this error:

rash report begins. Anonymous machine information:

amd64
14.0-CURRENT
FreeBSD 14.0-CURRENT #0 devel-main-n255797-d8d104eec65: Thu Sep 22 18:54:16 UTC 2022 root@freebsd:/var/jenkins/workspace/pfSense-CE-snapshots-master-main/obj/amd64/YVYTCXmQ/var/jenkins/workspace/pfSense-CE-snapshots-master-main/sources/FreeBSD-src-dev

Crash report details:

PHP Errors:
[23-Sep-2022 22:30:30 America/Tijuana] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(779) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(779): eval()
#3 /etc/inc/pkg-utils.inc(904): eval_once('squid_resync();')
#4 /etc/rc.packages(76): install_package_xml('squid')
#5 {main}
thrown in /usr/local/pkg/squid.inc on line 1610
[23-Sep-2022 22:30:36 America/Tijuana] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(713) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(713): eval()
#3 /etc/rc.start_packages(66): sync_package('squid3')
#4 {main}
thrown in /usr/local/pkg/squid.inc on line 1610
[23-Sep-2022 22:37:38 America/Tijuana] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(779) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(779): eval()
#3 /etc/inc/pkg-utils.inc(904): eval_once('squid_resync();')
#4 /etc/rc.packages(76): install_package_xml('squid')
#5 {main}
thrown in /usr/local/pkg/squid.inc on line 1610
[23-Sep-2022 22:37:42 America/Tijuana] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(713) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(713): eval()
#3 /etc/rc.start_packages(66): sync_package('squid3')
#4 {main}
thrown in /usr/local/pkg/squid.inc on line 1610

No FreeBSD crash data found.

The blog say that this changes will affect some packages, looks like squid is one of them.

I try to search but didn't see this bug?

If u need something extra please let me know.

2.7.0-DEVELOPMENT (amd64)
built on Thu Sep 22 18:30:19 UTC 2022
FreeBSD 14.0-CURRENT

Actions #2

Updated by Kris Phillips 2 months ago

Tested on September 30th build and problem is still present.

Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(779) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(779): eval()
#3 /etc/inc/pkg-utils.inc(904): eval_once('squid_resync();')
#4 /etc/rc.packages(76): install_package_xml('squid')
#5 {main}
thrown in /usr/local/pkg/squid.inc on line 1610
PHP ERROR: Type: 1, File: /usr/local/pkg/squid.inc, Line: 1610, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(779) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(779): eval()
#3 /etc/inc/pkg-utils.inc(904): eval_once('squid_resync();')
#4 /etc/rc.packages(76): install_package_xml('squid')
#5 {main}
thrownpkg-static: POST-INSTALL script failed

Actions #3

Updated by Kris Phillips 2 months ago

  • Status changed from New to Confirmed

Marking as confirmed

Actions #4

Updated by Kris Phillips about 2 months ago

Confirmed still present in Oct 7th builds.

Actions #5

Updated by Kris Phillips about 1 month ago

Tested on Oct 28th build of CE. Issue still persists for this package.

Actions #6

Updated by Jim Pingle 29 days ago

  • Parent task set to #13446
Actions #7

Updated by Reid Linnemann 28 days ago

  • Assignee set to Reid Linnemann
Actions #8

Updated by Reid Linnemann 28 days ago

  • Status changed from Confirmed to Pull Request Review
Actions #9

Updated by Kris Phillips 19 days ago

  • Status changed from Pull Request Review to Resolved

Tested on Nov 18th builds. Package installs properly with no more errors. Issue is resolved.

Actions #10

Updated by Jim Pingle 6 days ago

  • % Done changed from 0 to 100
Actions #11

Updated by Peter Moreno 4 days ago

Kris Phillips wrote in #note-9:

Tested on Nov 18th builds. Package installs properly with no more errors. Issue is resolved.

Yes, installed and working, thanks!!!

Actions

Also available in: Atom PDF