Project

General

Profile

Actions

Bug #13641

closed

PHP Error: squid.inc:852

Added by Steve Wheeler 3 months ago. Updated about 2 months ago.

Status:
Not a Bug
Priority:
Normal
Category:
Squid
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
23.01
Affected Architecture:
All

Description

Fatal error: Array and string offset access syntax with curly braces is no longer supported in /usr/local/pkg/squid.inc on line 852

Tested:

23.01-DEVELOPMENT (arm64)
built on Tue Nov 08 16:16:38 UTC 2022
FreeBSD 14.0-CURRENT

Actions #1

Updated by Jim Pingle 3 months ago

  • Parent task set to #13446
Actions #2

Updated by Reid Linnemann 3 months ago

  • Assignee set to Reid Linnemann
Actions #3

Updated by Reid Linnemann 3 months ago

This appears to perhaps have been generated post php upgrade and pre pfSense-pkg-squid upgrade, as I don't see any lines in the current source that could be interpreted as curly brace offset indexing.

Actions #4

Updated by Azamat Khakimyanov 3 months ago

on 23.01-DEVELOPMENT (built on Fri Nov 11 06:05:57 UTC 2022) when I tried to install Squid I got
Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(787) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(787): eval()
#3 /etc/inc/pkg-utils.inc(912): eval_once('squid_resync();')
#4 /etc/rc.packages(76): install_package_xml('squid')
#5 {main}
thrown in /usr/local/pkg/squid.inc on line 1610
PHP ERROR: Type: 1, File: /usr/local/pkg/squid.inc, Line: 1610, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/squid.inc:1610
Stack trace:
#0 /usr/local/pkg/squid.inc(2273): squid_resync_cache()
#1 /etc/inc/pkg-utils.inc(787) : eval()'d code(1): squid_resync()
#2 /etc/inc/pkg-utils.inc(787): eval()
#3 /etc/inc/pkg-utils.inc(912): eval_once('squid_resync();')
#4 /etc/rc.packages(76): install_package_xml('squid')
#5 {main}
thrownpkg-static: POST-INSTALL script failed

but final message was
"Please visit Services - Squid Proxy Server menu to configure the package and enable the proxy.

Cleaning up cache... done.

Success"

Actions #5

Updated by Reid Linnemann about 2 months ago

  • Status changed from New to Assigned
Actions #6

Updated by Reid Linnemann about 2 months ago

  • Status changed from Assigned to Not a Bug

I'm going to close this as not a bug, when we upgrade php we expect php errors before the packages are updated.

Actions #7

Updated by Jim Pingle about 2 months ago

  • Target version deleted (2.7.0)
  • Parent task deleted (#13446)
  • Plus Target Version deleted (23.01)
Actions

Also available in: Atom PDF