Project

General

Profile

Actions

Bug #13645

closed

Feature #13446: Upgrade PHP from 7.4 to 8.1

PHP errors regarding ssh

Added by Reid Linnemann 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Authentication
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

Found by Brad Davis
With no ssh section in the config, this can be hit:

Nov  1 13:45:25 pfSense php[33577]: Standard input code: New alert found: PHP ERROR: Type: 1, File: /usr/local/pfSense/include/www/system_advanced_admin.inc, Line: 55, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pfSense/include/www/system_advanced_admin.inc:55
Nov  1 13:45:25 pfSense php[33577]: Stack trace:
Nov  1 13:45:25 pfSense php[33577]: #0 Command line code(1): getAdvancedAdminConfig(true)
Nov  1 13:45:25 pfSense php[33577]: #1 {main}
Nov  1 13:45:25 pfSense php[33577]:   thrown

Actions #1

Updated by Reid Linnemann 3 months ago

  • Status changed from New to Pull Request Review
Actions #2

Updated by Jim Pingle 3 months ago

  • Project changed from pfSense Packages to pfSense
  • Category changed from sshd to Authentication
  • Release Notes set to Force Exclusion
Actions #3

Updated by Reid Linnemann 3 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Lev Prokofev 2 months ago

Tested on

23.01-DEVELOPMENT (amd64)
built on Fri Dec 02 06:04:48 UTC 2022
FreeBSD 14.0-CURRENT

No such errors after restoring the config with deleted SSH section.

Actions #5

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF