Project

General

Profile

Actions

Bug #13721

closed

PHP Fatal error - firewall_rules.php - FreeBSD 14.0-CURRENT #0 devel-main-n255818-a851396c4f4: Fri Dec 2 06:29:25 UTC 2022

Added by RED SKULL about 2 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:
amd64

Description

amd64
14.0-CURRENT
FreeBSD 14.0-CURRENT #0 devel-main-n255818-a851396c4f4: Fri Dec 2 06:29:25 UTC 2022 root@freebsd:/var/jenkins/workspace/pfSense-CE-snapshots-master-main/obj/amd64/ldySL2ES/var/jenkins/workspace/pfSense-CE-snapshots-master-main/sources/FreeBSD-src-dev

Crash report details:

PHP Errors:
[03-Dec-2022 20:21:11 America/Chicago] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/firewall_rules.php:54
Stack trace:
#0 /usr/local/www/firewall_rules.php(85): get_pf_rules(Array, 1623893679, 1623893679)
#1 /usr/local/www/firewall_rules.php(775): print_states(1623893679)
#2 {main}
thrown in /usr/local/www/firewall_rules.php on line 54
[03-Dec-2022 20:22:52 America/Chicago] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/firewall_rules.php:54
Stack trace:
#0 /usr/local/www/firewall_rules.php(85): get_pf_rules(Array, 11000, 11999)
#1 /usr/local/www/firewall_rules.php(539): print_states(11000, 11999)
#2 {main}
thrown in /usr/local/www/firewall_rules.php on line 54
[03-Dec-2022 20:23:13 America/Chicago] PHP Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/firewall_rules.php:54
Stack trace:
#0 /usr/local/www/firewall_rules.php(85): get_pf_rules(Array, 1667074168, 1667074168)
#1 /usr/local/www/firewall_rules.php(775): print_states(1667074168)
#2 {main}
thrown in /usr/local/www/firewall_rules.php on line 54

No FreeBSD crash data found.


Related issues

Is duplicate of Regression #13660: PHP8.1 error after applying floating rules changesResolvedReid Linnemann

Actions
Actions #1

Updated by Kris Phillips about 2 months ago

There is not enough information in this bug report. What was the steps/action(s) that caused this crash report to appear?

Actions #2

Updated by Reid Linnemann about 2 months ago

  • Assignee set to Reid Linnemann
Actions #3

Updated by Jim Pingle about 2 months ago

  • Status changed from New to Duplicate
  • Assignee deleted (Reid Linnemann)

Duplicate of #13660

Actions #4

Updated by Jim Pingle about 2 months ago

  • Is duplicate of Regression #13660: PHP8.1 error after applying floating rules changes added
Actions

Also available in: Atom PDF