Project

General

Profile

Actions

Regression #14502

closed

DHCPv6 Prefix Delegation (PD) not installing routes

Added by Jade Deane 10 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP (IPv6)
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Force Exclusion
Affected Version:
2.7.0
Affected Architecture:
amd64

Description

pfSense successfully hands out PDs, but does not install a route for them. This effectively causes traffic to black hole at the pfSense host, and not return to LAN hosts.

Issue occurred after upgrading to 23.05-RELEASE, and wasn't present in 23.01-RELEASE.

Scenario: pfSense receives /56 from ISP (WAN), and is configured within DHCPv6 to hand out /60s via LAN interface.

PD issuance:

/var/log/dhcpd.log:May 24 17:10:30 router dhcpd[34360]: Picking pool prefix 2600:xxxx:4f0::/60
/var/log/dhcpd.log:May 24 17:10:30 router dhcpd[34360]: Advertise PD: address 2600:xxxx:4f0::/60 to client with duid xxxx iaid = 1 valid for 7200 seconds

Post PD routing table, note lack of route for /60:

23.05-RELEASE][xxxx@router]/home/xxxx: netstat -6rn | grep em1
2600:xxxx:400::/64           link#2                        U           em1
...

Rolled back to 23.01-RELEASE, note existence of /60:

[23.01-RELEASE][xxxx@router]/home/xxxx: netstat -6rn | grep em1
2600:xxxx:400::/64           link#2                        U           em1
2600:xxxx:4f0::/60           2600:xxxx:35d5    UGS         em1
...

DHCPv6 staus

Thread previously opened several weeks ago per reporting guidelines: https://forum.netgate.com/topic/180346/dhcpv6-pd-not-installing-route-after-23-05-release-upgrade


Files

Actions #1

Updated by Jim Pingle 10 months ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from DHCP Server (IPv6) to DHCP (IPv6)
  • Status changed from New to Confirmed
  • Assignee set to Christian McDonald
  • Target version set to CE-Next
  • Affected Plus Version deleted (23.05)
  • Plus Target Version set to 23.09

Looks like this is happening because dhcpleases6 was removed from the base install in b63b534cb5fb10347f7fdc87818ac537de42ef0f and ports commit f17be094c2d8474cd89ef8d45679a05a42fe8286 but I don't see anything that replaced it yet for handling the routes. That used to fire off the prefixes.php script which handled the delegated routes.

It's possible I missed what should be doing that now, but even so, that would be a bug in whichever daemon is supposed to be monitoring the DHCPv6 leases.

Actions #2

Updated by Steve Wheeler 10 months ago

  • Target version changed from CE-Next to 2.8.0
  • Affected Version set to 2.7.0

See this here in 2.7 also.

Actions #3

Updated by Christian McDonald 9 months ago

  • Status changed from Confirmed to Feedback
Actions #4

Updated by Christian McDonald 9 months ago

  • % Done changed from 0 to 100
Actions #5

Updated by Georgiy Tyutyunnik 9 months ago

applied the patch to no effect, no routes were added for delegated prefixes
tested on:
Version 2.7.0-RELEASE (amd64)
built on Wed Jun 28 03:53:34 UTC 2023
FreeBSD 14.0-CURRENT

Actions #6

Updated by Christian McDonald 9 months ago

Georgiy Tyutyunnik wrote in #note-5:

applied the patch to no effect, no routes were added for delegated prefixes
tested on:
Version 2.7.0-RELEASE (amd64)
built on Wed Jun 28 03:53:34 UTC 2023
FreeBSD 14.0-CURRENT

You also need to
pkg install dhcpleases6

Actions #7

Updated by Georgiy Tyutyunnik 9 months ago

tested on
Version 2.7.0-RELEASE (amd64)
built on Wed Jun 28 03:53:34 UTC 2023
FreeBSD 14.0-CURRENT

Version 23.05.1-RELEASE (amd64)
built on Wed Jun 28 03:57:27 UTC 2023
FreeBSD 14.0-CURRENT

with package "dhcpleases6" installation patch works
pkg version: dhcpleases6-0.1_3
patch/changeset: 892d939ee0473992abece201ed3d5d2bfdfd276f

Actions #8

Updated by Christian McDonald 9 months ago

  • Tracker changed from Bug to Regression
  • Status changed from Feedback to Resolved
  • Release Notes changed from Default to Force Exclusion
Actions #9

Updated by Jim Pingle 9 months ago

For another confirmation point, I upgraded my edge to 23.09 dev snapshots and dhcpleases6 is running and I have route table entries for delegated prefixes again.

Actions #10

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions #11

Updated by Marcos M 2 months ago

The PD route is installed on 24.03 as well.

Regarding #note-11, that seems like a different root cause at least; I suggest discussing further on the forum.

Actions

Also available in: Atom PDF