Project

General

Profile

Actions

Regression #14534

closed

Cavium ``qlnxe`` / ``if_qlnxe`` driver is not present

Added by Nikolaos Astyrakakis 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
Hardware / Drivers
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:
amd64

Description

Interfaces using qlnxe driver are not appearing in 2.7.0 version.

I added if_qlnxe_load="YES" but the interfaces are not appearing.


Related issues

Related to Feature #11750: Support for network interfaces using the ``qlnxe`` driverResolvedViktor Gurov03/29/2021

Actions
Actions #1

Updated by Kris Phillips 10 months ago

Nikolaos Astyrakakis wrote:

Interfaces using qlnxe driver are not appearing in 2.7.0 version.

I added if_qlnxe_load="YES" but the interfaces are not appearing.

Was this working on a previous release and broke in 2.7.0? Or has this never worked?

Actions #2

Updated by Nikolaos Astyrakakis 10 months ago

Kris Phillips wrote in #note-1:

Nikolaos Astyrakakis wrote:

Interfaces using qlnxe driver are not appearing in 2.7.0 version.

I added if_qlnxe_load="YES" but the interfaces are not appearing.

Was this working on a previous release and broke in 2.7.0? Or has this never worked?

It was working on 2.6.0.

Actually, functionality was added on 2.6.0

Check Feature #11750

Actions #3

Updated by Jim Pingle 10 months ago

  • Tracker changed from Bug to Regression
  • Subject changed from Qlnxe driver is not working. to Cavium ``qlnxe`` / ``if_qlnxe`` driver is not present
  • Priority changed from Very High to Normal
  • Target version set to 2.8.0
  • Plus Target Version set to 23.09

I don't see the module in the builds or in the kernel configuration, but the string for it is still in MODULES_OVERRIDE as though it should be included. It's possible something in that driver changed upstream.

Actions #4

Updated by Jim Pingle 10 months ago

  • Related to Feature #11750: Support for network interfaces using the ``qlnxe`` driver added
Actions #5

Updated by Nikolaos Astyrakakis 10 months ago

Jim Pingle wrote in #note-3:

I don't see the module in the builds or in the kernel configuration, but the string for it is still in MODULES_OVERRIDE as though it should be included. It's possible something in that driver changed upstream.

Well, then we cannot update to 2.7.0 from 2.6.0 unless the driver is included in 2.7.x.
We are using Synology E10G21-F2 network card with 2 x 10G SFP+ ports that is based on Marvell FastLinQ 41000 Series network card. The card works fine in 2.6.0 version, for connection with WAN and LAN switches.
Is there any work-around to resolve this issue in 2.7.0?

Actions #6

Updated by Christian McDonald 10 months ago

  • Assignee set to Christian McDonald

I see the problem. I'm running a test build now to confirm. This will be resolved in the next release.

Actions #7

Updated by Christian McDonald 10 months ago

  • Status changed from New to Feedback
Actions #8

Updated by Christian McDonald 9 months ago

  • Status changed from Feedback to Resolved
Actions #9

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF