Project

General

Profile

Actions

Bug #14681

closed

IGMP proxy cause crash on 23.05.1

Added by Lev Prokofev 10 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
IGMP Proxy
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Crash trace attached, possibly related to https://redmine.pfsense.org/issues/12079

Fatal trap 12: page fault while in kernel mode
cpuid = 2; apic id = 02
fault virtual address = 0x0
fault code = supervisor read data, page not present
instruction pointer = 0x20:0xffffffff80f051cb
stack pointer = 0x28:0xfffffe006b373b30
frame pointer = 0x28:0xfffffe006b373b60
code segment = base 0x0, limit 0xfffff, type 0x1b = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags = interrupt enabled, resume, IOPL = 0
current process = 41302 (igmpproxy)
rdi: fffffe0008c45f18 rsi: 4 rdx: 1
rcx: 0 r8: 0 r9: fffff80007c29000
rax: 100 rbx: fffffe006b1d0900 rbp: fffffe006b373b60
r10: 0 r11: 2 r12: fffffe006b1d0900
r13: 0 r14: fffff800be213c00 r15: 0
trap number = 12
panic: page fault
cpuid = 2
time = 1691834148
KDB: enter: panic


Files

ddb.txt (233 KB) ddb.txt Lev Prokofev, 08/12/2023 12:54 PM

Related issues

Is duplicate of Bug #12079: Kernel panic when running IGMP Proxy: Sleeping thread owns a non-sleepable lockClosedMateusz Guzik06/25/2021

Actions
Actions #1

Updated by Kris Phillips 10 months ago

Did this issue crop up as a result of the patch in the linked redmine or does this crash happen without the patch?

Actions #2

Updated by Lev Prokofev 10 months ago

No patch was applied, because the patch requires a kernel build.

Actions #3

Updated by Jim Pingle 9 months ago

  • Is duplicate of Bug #12079: Kernel panic when running IGMP Proxy: Sleeping thread owns a non-sleepable lock added
Actions #4

Updated by Jim Pingle 9 months ago

  • Status changed from New to Duplicate

The backtrace looks close enough that it seems like the same bug. No reason for a new report at this point. Even if it happened on a fixed build it should be reported on the original issue.

Actions

Also available in: Atom PDF