Project

General

Profile

Actions

Bug #14683

closed

pfSense - Feature #13377: Option to configure a custom value for the PHP memory limit

PHP error on ``status_frr.php`` from using too much memory

Added by yon Liu 7 months ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
FRR
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

amd64
14.0-CURRENT
FreeBSD 14.0-CURRENT #1 plus-RELENG_23_05_1-n256108-459fc493a87: Wed Jun 28 04:26:04 UTC 2023 root@freebsd:/var/jenkins/workspace/pfSense-Plus-snapshots-23_05_1-main/obj/amd64/f2Em2w3l/var/jenkins/workspace/pfSense-Plus-snapshots-23_05_1-main/sources/

Crash report details:

PHP Errors:
[13-Aug-2023 01:24:15 Asia/Shanghai] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 524288008 bytes) in /usr/local/www/status_frr.php on line 77

Actions #1

Updated by Jim Pingle 7 months ago

  • Project changed from pfSense Plus to pfSense Packages
  • Subject changed from Allowed memory size of 536870912 bytes exhausted to PHP error on ``status_frr.php`` from using too much memory
  • Category changed from PHP Interpreter to FRR
  • Priority changed from High to Low
  • Release Notes deleted (Default)

Probably too much data for that page to deal with (e.g. route table is gigantic).

It already tries to limit how things are displayed to make this better but there may be room for improvement.

There is also a patch coming for the base system to allow PHP to use more memory which may help (#13377)

Actions #2

Updated by yon Liu 7 months ago

i have changed php tomemory_limit = 1200M now,it is ok.
and if run frr bgp route, the kern.ipc.maxsockbuf must be changed to a large value,i setup kern.ipc.maxsockbuf=1073741824.
If the value is the default frr package value, it will cause the system to crash.
Because frr often gets a lot of routes, the number of routes is likely to be tens of millions of routes

Actions #3

Updated by yon Liu 7 months ago

and changed config.inc

// Set memory limit to 512M on amd64.
if ($ARCH == "amd64") {
ini_set("memory_limit", "2048M");
} else {
ini_set("memory_limit", "128M");
}

Actions #4

Updated by Christopher Cope 7 months ago

  • Status changed from New to Duplicate
  • Parent task set to #13377
Actions #5

Updated by Christopher Cope 7 months ago

Since this is the same base issue solved by the PHP patch, I'm marking this as a duplicate of https://redmine.pfsense.org/issues/13377

Please follow that redmine for updates on the progress.

Actions

Also available in: Atom PDF